Usbtv driver missing on Vero4K

Just received my Vero4K. Wow, what a difference with my RPi2. I was quite happy with the performance but the Vero4K just blows it away.

That aside. I wanted to install hyperion on the Vero4K so I can get my Ambilight/Boblight installation up and running again but the usbtv-driver is missing. Is it possible to include it in the next update? Or how can I easily compile it myself? I tried it via the vero-sources but get a compile error: gcc: error: unrecognized command line option ‘-mgeneral-regs-only’


Glad to hear you’re enjoying the device.

I’ve already had a look at what’s needed to get Hyperion on the Vero 4K and will chase this up. I don’t know a lot about Hyperion so forgive me if I’m asking questions.

  • Are you using a USB based grabber?
  • What’s lsmod look like on a Pi?

It’s my intention to get Hyperion working well, not only for those using the remote mode but also for those using USB grabbers in the very near future.



Hi Sam,

I was using hyperion on my RPi2 with both dispmanx (for the RPi2) and an USB-grabber (Fushicai) for all other devices.
I think the relevant modules that are needed are these:

Module                  Size  Used by
usbtv                  13065  0
videobuf2_vmalloc       6150  1 usbtv
videobuf2_memops        2009  1 videobuf2_vmalloc
videobuf2_v4l2         31124  1 usbtv
videobuf2_core         30026  2 usbtv,videobuf2_v4l2
v4l2_common             6578  2 usbtv,videobuf2_v4l2
videodev              210827  4 usbtv,v4l2_common,videobuf2_core,videobuf2_v4l2
media                  18006  1 videodev

I’ve compiled hyperion with AMLogic and V4L support. Still looking howto configure the amlogic grabber so I hope that one works out of the box.
QT5 still seems impossible (Kodi fails when QT5 is installed) so I went back to QT4.

Hope this helps.

Hi Sam,

AMLogic grabber works as a charm. Working great on the Vero4K. Now I’m only missing the usbtv driver to get the V4L grabber running.

Also found this thread (OSMC and Hyperion - #17 by penfold42) which mentions support was added to hyperion-ng. AFAIK the new version requires QT5 which I never got working on OSMC. Kodi crashes when QT5 is installed.

Can you show me the crash log? They should not conflict.

I’ve added the usbtv module. It will be in the next kernel which will land in the next update. If you can provide some information re. Hyperion to other Vero 4K owners, that will be gladly appreciated :slight_smile:


Hi Sam,

These are the errors I’m getting:

20:22:46.670 T:4109280192   ERROR: AML: no rw on /sys/class/ppmgr/ppmgr_3d_mode
20:22:46.700 T:4109280192  NOTICE: InitWindowSystem: Using EGL Implementation: amlogic
20:22:46.895 T:4109280192   ERROR: EGL error in InitDisplay: 3001
20:22:46.895 T:4109280192   ERROR: InitWindowSystem: Could not create display
20:22:46.896 T:4109280192   FATAL: CApplication::Create: Unable to init windowing system

Easiest way to compile hyperion for Vero4K (top of my head)

$ sudo apt-get install git cmake build-essential libQt4-dev libusb-1.0-0-dev python-dev libxrender-dev python
$ git clone --recursive
$ cd hyperion
$ mkdir build ; cd build
$ make -j 4
$ sudo make install

Install this file as /etc/systemd/system/hyperion.service

After = mediacenter.service
Description=Hyperion Systemd service

ExecStart=/usr/local/bin/hyperiond /etc/hyperion/hyperion.config.json
ExecReload=/bin/kill -HUP $MAINPID


Create a config file in /etc/hyperion/ and make sure this is in it:

"amlgrabber" :
        "width" : 70,
        "height" : 40,
        "frequency_Hz" : 24.0,
        "priority" : 799

No clue if these are optimal settings, I got them from the hyperion website and they worked :wink:

Launch hyperion and cross fingers :slight_smile:


I think you may be installing full Qt 5 packages, which may be bringing in MESA. A full set of logs will show the introduced packages. This means Kodi is then picking the wrong libraries for display.

A new kernel is being built with your driver included. I’ll let you know when it’s ready for testing



I’m installing what appears to be needed to compile the sources. I’m currently compiling with QT5 support after which I will remove all packages and see which once are required for running the binary.


Installed all packages needed to compile hyperion. It pulled in MESA and a lot of other packages. After successful compilation I removed everything and just installed the packages/libraries needed to run the hyperion-binary. Kodi still seems to work. Will do some testing now.

You won’t need MESA for an AML grabber, probably safe to omit those packages.



Your missing driver should now be addressed in the following commit:

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hi Sam,

driver works like a charm. I now have a working hyperion on my Vero4K with both AMLogic and V4L grabber support.

Currently testing the QT5-build version which also seems to work without problems. The only issue with QT5 is that the environment to compile with QT5 support installs MESA libraries which break Kodi.

If people are interested, I can provide an install-file of the QT4-build with AMLogic and V4L support. It might require some additional packages to be installed (libusb, python etc…).


On the Pi, the mesa crap seems to be a mandatory dependency from qt5 and yes, it broke kodi starting for me too.

I worked around it by hacking the library search path in the mediacenter script.
(I think - I’m not near my Pi at the moment)

I never got it working on the Pi with your workaround. With limited packages for runtime it works on the Vero. For compilation it needs more packages which pull in Mesa and break Kodi.

I’m not a Debian expert so maybe this is a stupid question. I’m used to Gentoo Portage and FreeBSD ports which allow build options. To compile hyperion (and .ng) I need to install qtbase5-dev which pulls in opengl and mesa which break Kodi.Is there a way to get qtbase5-dev without pulling these in? I could probably remove the bad packages but how can I be sure they won’t be pulled in again on an update thus breaking Kodi again?