Use ethernet module ENC28J60 on Raspberry Zero

Hi, on my raspberry zero I installed an ethernet module based on chip ENC28J60 following: this guide.

But despite the changes to the configuration file are correct, and the driver is present on OSMC, the ethernet module does not work.
I tried also to enable the ASPI in OSMC settings but neither works.

does anyone know why?

P.S. with the latest version of raspbian working properly!

are you using OSMC or raspbian?

Has anyone had any luck in getting the ENC28J60 to life with OSMC? I have followed the advice that I found online (i.e. adding the lines “dtparam=spi=on” and “dtoverlay=enc28j60” to /boot/config.txt) but the device does not show up upon reboot. The device tree should be there (“ls /boot/overlays/enc*” shows the ENC28J60).

The device works with these changes on Raspberry Pi OS so I am ruling out a hardware issue. I have also tried LibreELEC out of interest and cannot get it to work on there either.

Am I missing something? Any help would be appreciated! :slight_smile:

Many thanks,

It’s not enabled in the OSMC kernel.

Raspberry Pi OS:

pi@raspberrypi:/tmp $ gunzip -c config.gz | grep -i ENC28J60 


osmc@osmc:/tmp/zero/boot$ grep -i ENC28J60 config-4.19.122-1-osmc 
# CONFIG_ENC28J60 is not set

Thanks for the quick response!

Is there a way to enable it without recompiling the kernel? I feel incapable of building the whole thing from scratch unless it is pretty straightforward. So far, the advice/ articles that I have found online have raised more questions than they have answered.

The article “Building OSMC completely from source” is referenced in the OSMC Wiki but I cannot find it. Maybe this would be helpful but I expect it to be too technical for my limited Linux skills.

I’ve made a note of this. A new kernel will be needed - but we can include support soon.

Edit: With that said, I don’t think Kodi v19 won’t support Pi0/1, so we won’t produce a new kernel for this platform and support will end with the final v18 release and our Buster release.

Thanks for the information! If I understand correctly, it will be unlikely for the ENC28J60 to ever work on the Pi Zero with a precompiled build. Maybe I’ll compile it myself one day but for the time being, I think I will be better off getting a USB Ethernet adapter to get a wired connection on the Pi Zero. Maybe it is also time to consider a Pi3 or 4 even though the Zero has worked perfectly for the last 18 month (except for various WiFi connection drops caused by the router hence the desire to get a wired connection).