Use limited color range yes or no

This is one of those settings I keep fighting with :slightly_smiling_face:
I have a LG OLED 77C8 and have enabled HDMI Ultra Deep Color on the HDMI port the Vero is connected to.
Now the question is do I disable the checkbox in KODI for: Use limited color range (16-235)?

If I understand the LG setting properly it will now display full range

You might want to read through this the following guide for more information…

but I believe the short answer is HDR (deep color in LG speak) isn’t impacted by that setting and for non-HDR source material the correct setting is normally to leave the limited range setting enabled. If your TV is not switching to HDR it may be to do with another setting. Please see the following recommends…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

That has nothing to do with quantization range AIUI. It basically switches on HDMI 2.0 support ie full 10-bit HDR at 4k 50/60Hz.

1 Like

Thank you for the detailed anwsers
I indeed already have all these settings:

  • Settings>System>Display>Resolution> 1920x1080p
  • Settings>System>Display>Whitelist> (empty) *
  • Settings>Player>Videos>Adjust display refresh rate> On start/stop

I haven’t played with the System>Display>Force 4:2:2 colour subsampling

If I enable Use limited colour range (16-235) on non-HDR content the blacks will look washed out, if I disable the setting blacks look thoroughly black.
On HDR content I haven’t noticed it yet.

Please post logs so we can check what’s happening. Reboot and play one of the videos you say is not displaying correctly.

1 Like

Will try to do that later today.

Here is the log with my default settings.
On non-HDR content the blacks can look a bit washed out and when viewing in a dark room it will start showing a lot of artifact in the blacks.

@grahamh, I’m als not sure if it is showing correct or not.
When Limuted range is on it will show more details in blacks but also give it a bit of a washed out look in the shadows and blacks.
When disabling Limited range the shadows look back but at the expense of loosing details.

This suggests you need to adjust the TV ‘brightness’ or black-level. Get hold of a PLUGE pattern such as the one in the calibration tools we link in the HowTo above and make sure blacks are distiguishable down to level 16 but no lower.

You mean the black clipping pattern?
I think I calibrated the TV way back when I got it with this.
Will give it another try tonight when it is dark.
Also running the ISF expert (Dark room) picture setup on the LG.

Just ran the black clipping and everything 16 and below do not flash

I prefer the APL clipping pattern because your TV may do some smart things depending on the average brightness of the picture. As an OLED, it’s not going to be messing with a backlight though. Try both.

The short answer to that is that if the display is something primarily designed to be used as a TV, you should use limited-range, and YUV. If the display is something that is primarily designed to be used as a PC monitor, you should use full-range and probably RGB.

If your display is a television and limited-range gives you washed-out blacks, then something is wrong - possibly with the source but more likely with the TV settings. There a few different TV settings which might be wrong. One is the Brightness; another (on my 2016 LG TV, I don’t know about your later model) is called “Black Level” and is found under Settings / Picture / Picture Mode Settings / Picture Options. You might also want to check the icon assigned to the input and make sure it isn’t set to “PC” - that can have a number of weird effects.

You can leave that box unchecked, unless you’re having problems with the HDMI signal dropping out; if you are, that setting may sometimes help.

I’ve been playing around with the calibration videos and the black level is set up properly. I think it is due to WebDL’s of certain shows with a bitrate that is too low and as a result get a lot of artifacts in the low lighting scenes.