Using IR with rPi2

Hello guys,

I messed around trying to configure my remote but deleted the symlink by accident. So how can I create back the symlink for the remote?

Also I used irecord in order to have a custom config file. I have it (Under /home/omsc/my-remote.lircd

How can I apply the config so I can make my remote work again (used to use Openelec).

Thanks

Marc

Check this out about locations for config files
https://osmc.tv/wiki/general/configuration-file-locations

Thanks But this doesn’t tell me how to recreate a deleted symlink. In fact I could find out how to create a symlink but I don’t even know what file to link?

Could someone give me that info?

Marc

The command you use is ln -s, and you can consult man pages for usage details.
I suspect that you need to link your lircd.conf to /etc/lircd.conf - but this is merely an informed guess.
Derek

Well I had to reinstall OSMV in order to have my symlink working again.

Now I’m back to square one. Need to configure my remote. rc6-mce seems to do the job BUT the “Select” or “OK” button doen’t work.

So I decided to create my own using irrecord and here is what it created: http://pastebin.com/ueJqGE3T

I installed it from the “Browse” action buttonm but then my remote won’t work at all. Any idea?

I think you’ll need o supply more info.
As a start, is /etc/lirc/lircd shown as linked to your newly generated lircd conf file? ( use ls -l /etc/lirc/lircd to show it).
And what Lircmap.xml are you using - does it have the same button names?
Derek

It seems it is linked:

lrwxrwxrwx 1 root root 30 Jan 8 11:07 /etc/lirc/lircd.conf -> /media/RECOVERY/my-remote.conf

Funny thing is that I dont have any lircmap.xml in kodi/userdata/

Where is its location? Even if I chose a preset remote, no lircmap.xml will show up but still able to use rc6-mce…

EDIT: Ok found it in /usr/share/kodi/system/lircmap.xml

Here is my lircmap.xml: http://pastebin.com/CQV8v2MS I just copy/paste what I added to original lircmap.xml the rest remains the same.

Customized it and then put it in osmc/.kodi/userdata/lircmap.xml and still not working…

This is getting a bit too much for me…

EDIT2: Also tried irw command and doesn’t show anything…

The only thing I can spot which might be slightly wrong is that in the lircmap you have the device name as my-remote, whereas in the lircd.conf you have my-remote.lircd. This doesn’t seem to accord, to me.
Apart from that you’ve duplicated my attempts, and also got to failure.
I’ve tried turning on debugging and watching the log, and find oddities which suggest that either the system is appropriating certain keystrokes or the mapping isn’t working the way documentation says.
Perhaps @DBMandrake might have a suggestion.
Derek

I really hope I can make this thing work 'cause I have domotic in my house and it makes it really easy to use the universal remote… Plus it used to work with OpenElec.

But thanks for your help. I may try it all over again.

It’s ALIVE! You know what @dandnsmith ? Changing the name did the trick!!

But Select button still deosn’t do anything and I have Strange behavior when looking a irw output:

Pressing once the UP buttons do Nothing, the second press does that:

67 0 KEY_UP linux-input-layer
67 0 KEY_UP_UP linux-input-layer

Then the third press NOTHING and the fourth the same as the second.

Same with every other key. Here is the SELECT button:

First: Nothing
Second:
161 0 KEY_SELECT linux-input-layer
161 1 KEY_SELECT linux-input-layer
161 2 KEY_SELECT linux-input-layer
161 3 KEY_SELECT linux-input-layer
161 4 KEY_SELECT linux-input-layer
161 0 KEY_SELECT_UP linux-input-layer
Third: NOTHING
Fourth: same as second

That’s not too bad becaude in OSMC I can go up, down, left right, but I cannot SELECT any menu option because select doen’t make any action in OSMC.

That the only point that really need to be working.

I’m almost there! :wink:

You’re experiencing the RC6 “toggle bit” where every other key press repeats and you recorded one of the two toggles. Best to use one of the included files for RC6 and modify it to suit your needs.

In fact I’m not using this remote. The only preset settings that was working was that one but the Select button wasn’t doing anything.

So I decided to record my own but still Select won’t select anything. Anyone can help me. As soon as Select button works, I’m happy!!

@Marc_C I think you need to change KEY_SELECT to KEY_OK in your lircd.conf file

Thanks @berto it works!!

Now I only have to fix that annoying thing that force me to press twice every key in order to move once… :frowning:

Marc