Using Realtek 8812AU wifi adapter possible?

Hi I’m trying to get prepared for when my 4K+ turns up,
I want to move my current 4K into a different room then and mount it on the back of the TV there, I’m guessing I wont get great wifi doing this so want to reuse the high gain USB adapter I have,
Windows reports this as a Realtek 8812AU device.
When I plug it into the spare USB port on my Vero 4K its blue light flashes as if its connected but when I go into my OSMC I have no option to select it, just the inbuilt wifi.
Is there something I need to do to disable the inbuilt wifi first or does the Linux driver for it need to be installed (if so how to do)?

P.S. I’d also like to use this adapter as it connects at over 800Mbps to my 5ghz wifi on the HTPC its currently connected to which I think is more than I’d get from the inbuilt wifi however I place the device in that room?


It will work. A customer requested RTL8812AU support for Vero 4K previously so it was added some time ago.

You might need to disable the built in WiFi. If you run sudo rmmod dhd via SSH, it should disable the internal WiFi (Bluetooth as well however) and let you use the external adapter.


Thanks @sam_nazarko I finally have some free time and will give it a try over the weekend.
I don’t use Bluetooth with it so that shouldn’t be a problem, if you wouldn’t mind what would be the command to re-enable the internal wifi if I need to?

You would remove the rmmod dhd line from rc.local. The command I’ve given you is not persistent across reboots; it’s just for testing.


Regarding mounting the Vero 4k to the back of a TV… Don’t rely on the sticky tape affixed to the supplied mounting plate. None of the four I’ve tried would hold to any surface for more than 24 hours before letting go, regardless of how clean the surface is before mounting. I resorted to small screws.


I’m trying to find ways to improve this.


Didn’t mean this in a critical way, just pointing it out to avoid the Vero dropping to the floor overnight. It is what it is, with heat from the Vero and mostly from the TV itself, even top quality removable adhesives (which it seems like the one used on the mounting plate is) will fail.

A couple short screws and a location on the TV back where there is some air void between the case and electronics, and you never have to think about it again.


No – I understand. I’m also keen on improving this.


Worked on my TV, holding for more than 12 months now

Sorry for resurrecting this old thread but I’ve finally got round to setting up my old original Vero 4K in the other room and I hope what I discovered may help someone else.
I don’t know why it didn’t show up before but without doing anything the high gain adapter I had now worked just by plugging it in.
However what I found was that no matter whether selecting wlan0 or wlan1 in the my OSMC network settings the internal wifi was always the one used by the Vero,
after some trial and error I found that disconnecting from and forgetting the network followed by disabling the wireless controller then powering down and powering back up and re-enabling the wireless has now allowed me to use the external adapter :slight_smile:
The result is via my 5ghz wifi I can now stream full uncompressed UHD rips perfectly, even the LG chess demo worked without a hitch whereas on the internal wifi it buffered for an eternity within 2 seconds :smiley:

Did you have a problem disabling the internal wifi? As Sam already mentioned, you need to remove the dhd kernel module, or better still blacklist it:

echo "blacklist dhd" | sudo tee /etc/modprobe.d/blacklist-dhd.conf

then reboot. Job done.

Actually I didn’t try disabling the internal wifi as Sam said the command he gave was not persistent across a reboot.
Thanks for your suggestion, I will try that soon, but as this was a typical 10 minute project that turned into and hour of frustration I think I shall leave the Vero be for the rest of the day lol.

I would also add not all Realtek 8812AU adapters are created equal, I have two from different manufacturers, both work just fine on Windows 10 but one of them gives worse speeds than the Vero’s internal adapter whilst the other is just perfect.

The adapters won’t be made equally. The 8812AU is just the chipset. The actual dongle is implemented by a variety of manufacturers.

I have run into one minor issue with this,
I may be wrong but I am assuming this adapter is being powered down after a period of inactivity?
I notice this because after being left for a while the Vero can no longer see my fstab shares when I go back to it as if its been disconnected from the server whilst the SMB ones still show up, a reboot will get the fstab folders working again.
If my theory is correct is there a command I can issue via SSH to stop the power down or should I just delete the fstab mounts and go with autofs?

It shouldn’t be powering down.

You can make sure power save is off with iwconfig wlan0 power off


FYI, iwconfig isn’t installed on OSMC, so you’d first need to install the wireless-tools package.