Using SQL Database for Video breaks Genre Filters and Chorus Web Frontend

Hi,

when I use the SQL Database for Video it breaks the Genre Filters and Chorus Web Frontend after some days.
This is my advancedsettings.xml:
… See Below …

After adding movies all is fine, The Genre Filter works and also the Chorus web Frontend.
But after a couple of days the Genre Filter shows this:

And Chorus is “Loading Movies” for Hours.

When I stop all Raspi’s, delete the tables and re-initialise the Database (QMariaDB on QNAP NAS), rescan the movies alls is fine again. - For some days.

Any hints what’s going wrong ?

Thanks

Markus

Hi

Can you paste the advancedsettings.xml on the forum here? Downloading files isn’t ideal for some of us.

Cheers

Sam

Sorry, how? Uploading doesn’t work: “Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, ico, bmp).”

XML is (relatively) human readable.

Copy and paste it, using code tags to format it properly.

Sam

copy paste and make sure to use the </>

<advancedsettings>
<loglevel>1</loglevel>
</advancedsettings>

here We go:

</><?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
	<videodatabase>
		<name>MyVideos</name>
		<host>192.168.2.2</host>
		<user>kodi</user>
		<pass>xxx</pass>
		<type>mysql</type>
		<port>3306</port>
	</videodatabase>
	<musicdatabase>
		<name>MyMusic</name>
		<host>192.168.2.2</host>
		<user>kodi</user>
		<pass>xxx</pass>
		<type>mysql</type>
		<port>3306</port>
	</musicdatabase>
	<videolibrary>
		<importwatchedstate>true</importwatchedstate>
		<importresumepoint>true</importresumepoint>
	</videolibrary>
	<pvr>
		<timecorrection>0</timecorrection>
		<infotoggleinterval>3000</infotoggleinterval>
		<minvideocachelevel>5</minvideocachelevel>
		<minaudiocachelevel>10</minaudiocachelevel>
		<cacheindvdplayer>true</cacheindvdplayer>
		<channeliconsautoscan>false</channeliconsautoscan>
		<autoscaniconsuserset>false</autoscaniconsuserset>
		<numericchannelswitchtimeout>1000</numericchannelswitchtimeout>
	</pvr>
</advancedsettings></>

If it affects all connected pi’s, it’s almost certainly an issue with the DB/NAS. You should provide a complete set of debug enabled logs next time the issue appears.

Yes, it affects all RPI’s on the network.
This is the Genre Screen when all is OK:

And this it what it looks alike after it’s broken:

There is not much about logs to see on the QNAP NAS.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Where to Enable Debugging? On all RPI’s or on just one?

I think just one should be sufficient.