Using sudo over ssh connection

Hi and following on from getting passwordless ssh into my OSMC on RPi and VPN working correctly, I have three questions:-

1.What is the correct way to run sudo apt-get install psmisc over ssh from my workstation terminal?

2.I ask the above because, having installed VPN which is working fine, I can no longer esc to terminal screen to be able to run sudo commands from terminal of osmc machine.

If I run an installation as exampled above over ssh, will I have ownership issues because I ran from workstation not on RPi machine?

Hi,

The same way you issue the from the esc terminal issues.

No permissions issues, as the permissions are to do with user you’ve logged in as (omsc); not the workstation you’ve logged in from.

Thanks Tom.

Hi Tom,
Thanks for the reply. Not sure I follow but the esc method does not work any more and neither does holding down ctrl. If I use the esc method the system tends to freeze. I have read the several threads and the wiki but still no joy here.

I tried using the sudo command from my terminal with ssh to RPi and received an error. Tried again following your message and this time it worked so thanks for that.

Hi,

Glad to hear you got the command working.

Although your system shouldn’t be freezing when trying to access the command line; when it pressing escape.

It maybe worth providing some logs, so we can try try and work out whats going on:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.