Using VPN with Vero 4K+ Slows Connection by 80%


#1

My apologies if this has been discussed before but after spending a long time looking into it I was never able to find an official solution in the forums.

My Vero 4K+ is connected via ethernet cable however, when I run IPVanish (through Zomboided/OpenVPN) it kills my connection speed. With my VPN off and using the speedtest.net addon I get speeds around 250 mbps. Once I connect to the VPN the best speed I get is around 50 mbps. I tried connecting to around 25 different servers within IPVanish and none of them were able to achieve anything above 50. From what I’ve read it sounds like it’s a CPU issue but as I mentioned above, I couldn’t find a solution that was realistic for me to try. Does anyone know if there is a way for me to fix this? Thank you in advance

Darren


#2

Can you check the CPU Load while you do your speed tests?
IMHO it is the CPU which is limiting the max speed available.


#3

Same here on my Synology … that is the nature of using a strong cypher with your VPN.
If you have the change to select weaker and thus less demanding cyphers it will be easier on the CPU, that will increase the connection speed again.


#4

There was a thread somewhere where this was mentioned, and I think it was discussed that openvpn could be compiled with hardware support or acceleration or something along those lines to improve performance, …I’m not sure if it ever got implemented or not.

I’m sure one of the osmc devs can chime in and clarify.


#5

Yes – in theory it can. We’d need to build OpenVPN and OpenSSL downstream however.
This might make setup a bit tricky for some users.


#6

Sorry if this isn’t what you are looking for but what I did for this was enable debug logs so the CPU usage is displayed in the top left corner. Using the “CPU-KODI” percentage that is displayed I came up with these numbers: With the VPN running my CPU load would spike to around 140% on initial startup of the speedtest. As the speedtest ran that percentage would fall to around 40%-65%. Now, with my VPN disconnected, I would get a similar spike on initial startup to around 140%. However, as the speed test continued to run the percentage would hover around 100%. I was expecting the numbers to be the opposite but I’m not that smart so maybe that’s to be expected. Please let me know if you were looking for something different.

Is there a VPN that works better but still provides a legit level of security and anonymity?

Thank you - I did see that thread but as Sam mentions below, it doesn’t seem like an easy fix is available yet.

I appreciate all you do - Thank you


#7

Have you tested if that VPN server is even as fast as your own internet connection?

I know mine is around 10 times slower then my 200Mbit connection at around 20Mbit.


#8

Yes, I have. I have IPVanish installed on several devices and they have no problem reaching around 150 - 180 mbps (250 Mbit connection)


#9

And what CPU you have on these devices?


#10

OpenSSL is already compiled to take advantage of the Vero4K’s crypto extensions.


#11

A VPN encrypts the traffic; this consume CPU cycles. Small CPU’s (and those lacking an FFP) are hindered by running a VPN at the same time as their primary tasks. You can offload the encryption to a router with at least 2 cores, helping the Vero perform its primary task, but the router (I use a Netgear R7000 running DD-WRT) takes a hit as well turning my download speed from 150 Mbps to 50 – enough that a high def stream can still reach me at >15 Mbps. On my home computers, the VPN hit is negligible, but for my tablets, phone and Vero, the wireless router with PIA is my best option. For all non-VPN traffic I use a secondary router on a different IP address.

Any help?


#12

Reason I use a J1900 Cpu based router with 4 Intel 1Gbps cards.
Manage to get 180Mbps throughput on that while using up only 1 Core, with high encryption grade active. But I don’t use VPN for streaming.


#13

I had a quick look at IPVanish and it seems to use AES-256-CBC encryption, together with SHA256 (HMAC) authentication.

On my local network, I’m able to get around 87.5 Mbits/sec in iperf3 using the above parameters on a Vero4K (not plus) with CPU running at a bit less than 70%.

Pro rata, I would therefore expect a Vero4K+ to be able to get over 100 Mbits/sec on a local network, so any reductions you are seeing are likely to be down to server response, and general network latency.


#14

I’m really sorry if this is a stupid question as I hate to waste your time dealing with what seems to be something you’ve already spent time on.

I’m not nearly as smart as 99% of the community here so I was hoping for a little clarification on your last 2 replies.

I read the entire thread that you attached (thank you for that) and the other threads within that one. However, I didn’t see anything that explained what I needed to do to achieve those results? Or was it saying that it’s been implemented since then? Again, this could just be my ignorance. Thank you for your help and patience.


#15

It had already been implemented when I ran the tests a few months back. The crypto extensions of the Vero4K/+ will automatically be used without you needing to do anything. (You only need to act if you wish to switch off the crypto extensions.)


#16

My only contribution to this thread is to mention CPU temperature.
I see where CPU load percentage has been mentioned, and it is important, but my limited understanding is that a hot CPU may throttle back to prevent overheating. I dont know if the vero has a heatsink or a fan but it would occur to me that when it is showing 60% CPU load with VPN that it may be limited or throttled to 60% load because of the CPU temp nearing max operating temp.
Maybe perform your tests and then repeat with a fan blowing directly into the device. I dont own a vero so I have no idea what I’m talking about. I just wanted to bring the temp parameter into play. It would explain why CPU load was higher without vpn and why its slower at lower load percentage.


#17

Temperature throttling might be a factor, though not one I’ve tested for.

It’s also worth noting that the Vero4K/+ is a 4-core device and the 70% CPU figure I quoted is for one core only, so the device isn’t being pushed that hard. (OpenVPN is a single-threaded application.)


#18

What temperatures are you seeing?


#19

During just standard operation (not running any addons) I’m seeing around 150 degrees


#20

That’s 65C which is fine.