V18 update - adv(x2) deinterlace lagging/jerky

After the update to Kodi v18, 1080i MPEG2 Live TV and DVR recordings lag compared to the audio by upto a second or so, and the picture is jerky - as if frame are being dropped in an attempt to catch up (although the ctrl-shift-O stats don’t record any dropped frames) when the “Deinterlace method” is “adv(x2)”

Other deinterlace methods appear fine, but “Auto select” picks adv(x2). I seem to be able to set the deinterlace method for TV channels and they are remembered, so that is a reasonable workaround for live TV, but DVR recordings always default to “auto select” and hence “adv(x2)” and I can’t find any setting to make it not use adv(x2).

Not a show-stopper, but it is a little annoying to have to re-set the deinterlace method each time.

This is on a Raspberry Pi 2 that did not have this problem before the update to Kodi v18, although I vaguely remember something similar happening on an earlier Kodi version update … Found it !!! … [TESTING] Kodi 17 (Krypton) Beta Builds for all platforms - #423 by popcornmix

Do you have the MPEG2 license?

Looks like this may be a specific quirk for Pi1, Pi2.

Yes, I have the MPEG2 license.

I also tried adding “core_freq=400” to config.txt, as suggested in the previous thread (linked above) , but that didn’t solve the problem.

I have the same problem with jerky video on a Pi2 v1.2, though the sound is fine. Installing the same SD card in a Pi3 (original version) works OK. Neither card has the MPEG access code loaded.

The pi is only running Kodi; video is from a separate TVHeadend server.

Switching interlace from the default “adv(x2)” to “Bob(x2)” (the default on v17) solves the video problem. On the same hardware running v17, switching interlace from Bob(x2) to adv(x2) causes the jerky video to appear. It does seem therefore that the wrong interlace method is being used as default on this hardware.

Incidentally, the snooker playing on UK TV this week is an excellent test. The interlace problem causes the balls to move unevenly across the table.

Bumping to add this additional info.

I initially thought that Deinterlace Method “Auto Select” was using Adv(x2) in v17 on my RPi2. However, I just restored to v17 and discovered that “Auto Select” was using Bob(x2) which is why it was working.

So the new problem isn’t that Adv(x2) doesn’t work with 1080i on a RPi2 … it never did work.

The problem is that v18 Deinterlace Method “Auto Select” makes a poor choice for 1080i files on a RPi2. The “Auto Select” choices made by v17 were better.

Agreed. Will see what can be done to remedy this.

Any update on this? Hopefully the more significant issues of the version update have been resolved and a minor thing like this can now be looked at.

The workaround of manually switching “Deinterlace method” is simple enough, but its a pain to have to do it every time.

You should be able to set it as default for all videos


Short answer …

Thanks, that works.

TL;DR answer … (in case anyone else has a RPi 2 and is annoyed by the same thing)

I had actually thought of trying to change the “default” setting, but I made the mistake of looking through all of the “System” > “Settings” options but never found anything to set a default interlace method. It ever occurred to me that the way to do it is …

  1. play a video,
  2. change the “Deinterlace method”,
  3. and while still in “Video Settings”, select “Set as default for all media”

Its not perfect since it will also change the “Dinterlace method” on SD videos that can handle adv(x2) which is presumably better than using other methods, but its probably not a difference that I would actually notice in most cases, so its good enough as a “fix”.