V4L videograbber not working with Pi2

I have this bideograbber that worked perfectly and out of the box on a Pi 1.
But now I connected it to a Pi 2 with osmc and it doesn’t create the /dev/video0 device it did on the Pi 1.

Here is the dmesg output (audio seems to work but not video)

4.350275] Linux video capture interface: v2.00
[ 4.413041] em28xx: New device USB 2861 Device @ 480 Mbps (1b80:e302, interface 0, class 0)
[ 4.413072] em28xx: Video interface 0 found: isoc
[ 4.413538] em28xx: chip ID is em2860
[ 4.417791] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 4.573660] em2860 #0: EEPROM ID = 1a eb 67 95, EEPROM hash = 0x8d9c6840
[ 4.573700] em2860 #0: EEPROM info:
[ 4.573716] em2860 #0: AC97 audio (5 sample rates)
[ 4.573727] em2860 #0: 500mA max power
[ 4.573742] em2860 #0: Table at offset 0x04, strings=0x226a, 0x0000, 0x0000
[ 4.573773] em2860 #0: Identified as Pinnacle Dazzle DVC 90/100/101/107 / Kaiser Baas Video to DVD maker / Kworld DVD Maker 2 / Plextor ConvertX PX-AV100U (card=9)
[ 4.573806] em2860 #0: analog set to isoc mode.
[ 4.574218] em28xx audio device (1b80:e302): interface 1, class 1
[ 4.574408] em28xx audio device (1b80:e302): interface 2, class 1
[ 4.574612] usbcore: registered new interface driver em28xx
[ 4.702790] usbcore: registered new interface driver snd-usb-audio

Anyone has the same problem or knows a solution?
This is with the latest Juli update.

Here is the output of lsmod. Seems to be right?

em28xx 79799 0
tveeprom 13975 1 em28xx
v4l2_common 6434 1 em28xx
videodev 188498 2 em28xx,v4l2_common
media 17918 1 videodev

Edit: I noticed that lsusb is missing. Is there a reason for this?

Edit2: Is there even v4l(2) support in the osmc kernel?

Are you having trouble with hyperion or just the grabber? There was an issue with a recent update that caused SPI to not get enabled. If you manually update via My OSMC -> Updater -> Manual Controls -> Check for Updates now it should resolve that issue. I’ve been using a grabber card on OSMC / Pi 2 for months without issue.

Hyperion works perfectly fine for normal movie watching, but I want to add a framegrabbber (renkforce dvd maker II) to make it work with hyperion-v4l and an external video source.

All that worked perfectly on a Pi1 with osmc, but not on the pi 2. So I suspect that raspbian handles the hardware differently than debian jessie.

I have the same problem with OSMC on Pi 2: Video grabber worked fine on Pi 1 with RaspBMC, but does not work on Pi 2 with OSMC.

Have no solution yet. Details:

osmc@osmc:~$ cat /etc/os-release | grep VERSION_ID

osmc@osmc:~$ grep Kodi .kodi//temp/kodi.log | head -2
12:45:39 T:1956765696 NOTICE: Starting Kodi (14.1 Git:Unknown). Platform: Linux ARM (Thumb) 32-bit
12:45:39 T:1956765696 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)

osmc@osmc:~$ lsusb
Bus 001 Device 006: ID 0781:5583 SanDisk Corp.
Bus 001 Device 005: ID 05c7:7001 Qtronix Corp.
Bus 001 Device 004: ID 1b80:e302 Afatech
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

osmc@osmc:~$ dmesg | grep em28x
[ 5.080988] em28xx: New device USB 2861 Device @ 480 Mbps (1b80:e302, interface 0, class 0)
[ 5.081024] em28xx: Video interface 0 found: isoc
[ 5.081377] em28xx: chip ID is em2860
[ 5.246944] em28xx audio device (1b80:e302): interface 1, class 1
[ 5.247026] em28xx audio device (1b80:e302): interface 2, class 1
[ 5.247295] usbcore: registered new interface driver em28xx

Above output looks fine for me, yet there is no /dev/video0, no /dev/video1, …

Does your device require firmware?


The kworld dvd maker 2 shouldn’t need firmware.
The driver seems to be working, but video0 node in /dev is not created.
v4l-info says there is no device video0, so it expects it to be there, but it isn’t.

  1. I agree with mcobit’s answer.

  2. When I was googling for the problem many weeks ago I remember that some guy had a similar problem (I believe with his WebCam) also on Pi 1 with RaspBMC and basically he was telling that it was introduced by some kernel update and switching back to an older kernel would help.

@mcobit has some news :wink:


I built a kernel with em28xx v4l2 support.
It will also be supported in next month’s update.
If you don’t want to wait, pm me and I can upload it somewhere.

Sounds great!

If you have some webspace for upload feel free to upload, mcobit. But if not, no problem. I can wait for the next update. Or perhaps I can figure out how to compile the changes you committed myself…

I’ll upload tomorrow

Here is a kernel with the changes:

Install it with

wget http://collaborate.osmc.tv/index.php/s/YCJRZBE9vjWY3o3/download
sudo dpkg -i rbp2-image-4.2.3-2-em28xx-osmc.deb

Downloaded and installed. Thank you so much, mcobit!
/dev/video0 is available now on my Pi 2. :slight_smile: