Various issues starting around the November update

I’ve been having some weird issues that started around the November update, possibly a bit before (I’m not entirely certain it started at that time), but the issues are getting worse.
Issues currently are: scanning for new content is painfully slow.
Starting to play content is painfully slow and may freeze the display.
Stopping content is painfully slow and may freeze the display, sometimes the display just shows a bunch of smearing noise when stopping playback for a bit of time, in the past it was just a clean stop and back to the menu.
I just enabled logging and when I stopped playing content the display froze - even logging activity froze (no writing to the log file after that point), although the unit still remains accessible via ssh.
The vero4k+ is using wifi and the content is shared via read only nfs.
I’m considering a fresh install, but want to save my “watched” information. Don’t really want to import a full library backup in case the library db is in a corrupted state.
Any input or further troubleshooting hints would be useful.
Thank you,

Hi Chris,

It’s hard to speculate without some logs being made available here.

If you can reproduce this again, the output of grab-logs -A would be useful.

Video crash at end of this log:
Seems the crashes are, at least more frequent, when I’m using HEVC content, as a couple of other files started and stopped before the crash.
Was still able to shell in. Note that I was running with log enabled for quite a while, and I attempted to do a library export with separate files which apparently does not write to a usb drive but to the content share, which failed as it’s read only.
Is the watched information only in the database files and not in the library?

The database is the library. There are options for exporting and importing in Kodi.

You can also backup and restore via My OSMC.

I see multiple playback attempts without issue. It would help if you could tell me the name of the HEVC file which did not play

I’ve had the trouble with many of these x265 encoded files, all play fine on my desktop. This happened to be Endeavour S08E03, start of playback was slow and when I hit stop (after a short time) the video froze, although this time the system did keep writing to the log and I was able to shell in and upload. The system also stopped responding to the remote.

In regards to the library, the backup has no .db files, just the one .xml, videodb.xml. Is the watched data in there? If so what’s the best tool to locate it?

I can see a number of connectivity issues in your log. Are you able to run an Ethernet cable temporarily to see if this alleviates the problem?

When you do a library export from Kodi the separate files option places the metadata next to the content itself which requires write access to that location. However the single file option lets you choose the location you want it written to. Do note that when you import a library from a single file or just start a new library using the nfo files that were written during a separate files export, by default this does not import watched status. To enable the watched status import you must do so with an advancedsettings.xml file…

Alternatively you may want to use something like Trakt which stores this information in the cloud.

An xml file is just a text file. The file generated from a single file export is going to be larger than what you would want to try opening with most basic text editors though. Notepad++ is a good option that doesn’t have issues with file size.

Doubt I have a cable long enough but I’ll look. Device worked perfect for the longest time even 4k HD would transfer just fine via WiFi. All other WiFi devices are working fine.
Is it possible the radio on this device is having issues?

Here’s a new log, playback started on, when I hit stop the video froze. Also the system stopped writing to the log file although I could still shell in.

I think I’m narrowing in on the issue.
Ever since I purchased the Vero4k+ in January of 2020 it has been connected to my Oppo BDP 105 instead of my display, for the very good reason of using the Oppo’s very fine DAC’s to decode the audio. The Oppo also acts as my home theater processor. It’s analog out’s directly feed my amplifiers. The Vero’s audio passthrough ability makes this an ideal marriage and overcomes this old Oppo’s weaknesses (slow WiFi, no support for HEVC, x265, etc.).
The problem appears to be that now that the Vero will no longer allow me to set the proper display resolution of 1920x1080 (which is the native resolution of my display). If I set that resolution I can no longer see any video. After a power on reset the Vero comes up with 1280x720 in the display settings. This seems to be the cause of the problem. If I connect the Vero directly to the display and set the video resolution to 1920x1080, the content, including HEVC, starts, displays, and stops just fine (as it did until recently).
I don’t think it’s the Oppo’s fault as my Chromecast works fine, seems like something changed in the Vero’s display detection.


Your Oppo shows that it supports 1080p.


You could try making sure it is powered on first before powering the Vero.

Yes, and the Oppo can even upscale to 4k if connected to such a display.
It’s looking like a possible poor HDMI cable connection, after applying some Deoxit and re-seating all of the HDMI connectors the Vero once again displays video at 1920x1080.
Hopefully that was the fix.
Thanks you for all of your assistance!

Let’s keep an eye on things.

I hope that this is the solution for you



Still having issues. Decided to try a fresh install, seemed to go OK, but after it came up the remote doesn’t work so I can’t finish the setup. Will see what I can find on that.

The remote may have been in the white USB port.
This is fixed in the December 2021 version and an image for that will be available on the Downloads page soon.

I moved it to the other port and it worked.

You can install updates now and the port will start working again.

Scanning is still problematic, logs show:

2021-12-25 21:57:16.437 T:3502 INFO : CPythonInvoker(254, /usr/share/kodi/addons/ script successfully run
2021-12-25 21:57:16.535 T:3503 INFO : initializing python engine.
2021-12-25 21:57:16.761 T:3502 INFO : Python interpreter stopped
2021-12-25 21:57:18.872 T:3151 ERROR : GetDirectory - Error getting
2021-12-25 21:57:18.874 T:3503 WARNING : Attempt to use invalid handle 254
2021-12-25 21:57:18.875 T:3503 INFO : CPythonInvoker(255, /usr/share/kodi/addons/ script successfully run
2021-12-25 21:57:18.972 T:3504 INFO : initializing python engine.
2021-12-25 21:57:19.197 T:3503 INFO : Python interpreter stopped
2021-12-25 21:57:21.253 T:3151 ERROR : GetDirectory - Error getting
2021-12-25 21:57:21.255 T:3504 WARNING : Attempt to use invalid handle 255
2021-12-25 21:57:21.256 T:3504 INFO : CPythonInvoker(256, /usr/share/kodi/addons/ script successfully run
2021-12-25 21:57:21.346 T:3505 INFO : initializing python engine.
2021-12-25 21:57:21.574 T:3504 INFO : Python interpreter stopped
2021-12-25 21:57:23.631 T:3151 ERROR : GetDirectory - Error getting
2021-12-25 21:57:23.634 T:3505 WARNING : Attempt to use invalid handle 256

Just keeps repeating with the handle incrementing by 1.

I also get these in dmesg:

[ 612.732365] wl_run_escan: LEGACY_SCAN sync ID: 2, bssidx: 0
[ 914.883948] wl_run_escan: LEGACY_SCAN sync ID: 3, bssidx: 0
[ 1217.042565] wl_run_escan: LEGACY_SCAN sync ID: 4, bssidx: 0