Vero 2 bricked during first update


my Vero 2 bricked during the first update via " My OSMC".

I Installed an update which was found by " My OSMC" for my new Vero 2.

The installation-process started as I know it from the Raspberry Pi 2 and Pi Zero. But after the reboot the screen kept black for more than 30 minutes. I cannot connect to the box by SSH, too.

How can I reinstall the OSMC-image ony the NanD of my Vero 2?


Hi Mark

Go to Download - OSMC and download the installer for Windows, Mac or Linux. You can then grab the January image there.

@DBMandrake made some changes to the way the framebuffer is initialised in the last update. Try and update again and if this gives you the same issues again, then this may be the issue.


Hi Sam,

I downloaded the Vero 2 image already twice. In a first attempt, I wrote the extracted image with Win32Disk Imager on a formatted SD-Card and put this card in the slot of the Vero 2…no reaction-whwn trying to boot - the screen still stays black. In a second attempt, I downloaded the Image with the installer for Windows on the SD-Card…same issue - screen strays black and no reaction :cry:

Is there a hidden reset-buttonin in the A/V port, as known from other Amlogic Boxes or how can I start the bootloader?


What HDMI mode does your TV report if you press your remote’s info button ?

Can you try a different screen ?

Also how long did you wait ? It can take about 30 seconds before the installer will appear.

Hello Simon,

no chance to try or change anything. My TV-Monitor stays black. I cannot get in contact with the box via SSH, too and the Vero 2 isn´t shown in the local newtork anymore. Only the blue LED still shines.

I waited more than 5 Minutes, before I disconnected the power plug. I already connected serveral boxes to my TV before and never had a problem and the Vero 2 worked before the update-Attempt, too.


Try re-imaging the SD card with the installer again, try to boot off it and leave it for 10 minutes.

Then turn the power off and put the SD card back in your PC - if the installer failed to run at all there will still be the two files ‘kernel.img’ and ‘filesystem.tar.xz’ on the disk. However if the installer ran these files will be deleted and there will be an installer.log file instead.

If so please paste the contents of this log at and provide the link.

Also if you do find an installer.log try powering the device back up with no SD card, wait a minute then see if you can connect via SSH to osmc.local. (You will need iTunes or Bonjour for Windows installed for a windows machine to be able to resolve osmc.local)

…I´ll try tomorrow. It´s time for bed now :sleepy:

same problem here
received my very yesterday, did a kodi upgrade today, vero2 is bricked…
first reboot, had this message:

second reboot, this one:
[can’t upload two images as new user, how silly is this :slight_smile: ]

and then, nothing, no boot screen, no image at all …

I tried to re-install with SDCard and it worked:

Thu Jan 1 00:00:07 1970 Starting OSMC installer
Thu Jan 1 00:00:11 1970 Detecting device we are running on
Thu Jan 1 00:00:11 1970 Mounting boot filesystem
Thu Jan 1 00:00:11 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:11 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:11 1970 No preseed file was found
Thu Jan 1 00:00:11 1970 Creating root partition
Thu Jan 1 00:00:15 1970 Calling fmtpart for partition /dev/vero-nand/root and fstype ext4
Thu Jan 1 00:00:27 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
434176 inodes, 1734656 blocks
86732 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1778384896
53 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632

Allocating group tables: 0/53 done
Writing inode tables: 0/53 done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 0/53 2/53 4/53 6/53 done

Thu Jan 1 00:00:27 1970 From a root partition of /dev/vero-nand/root, I have deduced a base device of /dev/vero-nand/roo
Thu Jan 1 00:00:27 1970 Mounting root
Thu Jan 1 00:00:27 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:00:27 1970 Using device->root: /dev/vero-nand/root
Thu Jan 1 00:00:27 1970 Extracting files to root filesystem
Thu Jan 1 00:00:27 1970 Starting extract progress…
Thu Jan 1 00:01:51 1970 Extraction of root filesystem completed
Thu Jan 1 00:01:52 1970 Configuring bootloader
Thu Jan 1 00:01:52 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:01:58 1970 Configuring boot cmdline
Thu Jan 1 00:01:58 1970 Configuring /etc/fstab
Thu Jan 1 00:01:58 1970 Successful installation. Dumping log and rebooting system

But now I have to re-scrap all my content. Can I backup this ?

PS: I still get a libCEC not found at startup, maybe it’s not implemented yet ?

I’m not sure the device is bricked

Have you tried reloading the software?

libCEC will land very shortly


in my case, there is still no progress, because I was not at home until Friday. I 'll start another attempt in the way Simon explained, monday evening.


For me, reinstalling worked, but no more updates for me :wink:


I re-imaged the SD card with the installer again, tried to boot off it and left it for 30 minutes. Back in the PC, I can see that the installer failed to run: There are still the two files 'kernel.img’ and ‘filesystem.tar.xz’ on the disk.

I tried 2 different HDMI-Monitors, too. All the same. There is something like a Video-signal, but it´s totally black.

What should I do? :fearful:


it might be the SD card, can you try another one?


I tried it with 2 other SD-cards. It`s all the same. The box does not boot anymore.

@sam_nazarko So I arrived at the conclusion that I have to send it back, so that you can repair it or send me another one. Please contact me for further details.


You would be wise to use email as specified here

I have received your email and will follow up briefly