Vero 2 crashes consistently

Got my vero 2 today. Got the latest updates (Feb 29 fix), but I also set my clock to march 1 for testing purposes. Either way the Vero crashes either while I’m entering the wifi password or just while it starts to try and connect.

The error comes in two flavors. Sometimes its just the frowny face, other times the screen gets fuzzy and I get a lot of audio feedback (non responsive to input).

I have no idea which log files to upload, so I just dumped them all (sorry if that is too much):

Thanks for all your time!

As it looks like the connection to wifi is successfully created before you get the sad face.
Mar 01 15:45:44 osmc connmand[354]: wlan0 {add} address label wlan0 family 2

So it might actually one of the addons that you installed that crashes the Vero. Maybe you can try to temporary remove that addon and test if you can successfully use wifi without it.

The sad face crash when entering the wifi passphrase for the first time is a well known bug in My OSMC that has been there for a long time and exists on the Raspberry Pi as well. We are doing a ground up rewrite of My OSMC so that will be solved eventually. It does not prevent the wifi connection from being saved so you should find your wifi connection is working when Kodi starts again.

As for the fuzzy screen and audio - we would really need to see a picture of the screen to see what you mean by “fuzzy”.

I’ve removed the add-on, but the error persists. I got Wi-Fi to work, but this happened when setting up subtitles.

It’s fuzzy and shaky, so I took two pictures to illustrate. I’m going to do a full wipe and reload next, but other thoughts are appreciated.

This log file paste was done after rebooting, directly after those pictures were taken. Note sure if it shines any light on this or not.

(Also, very cool feature. Makes logs super simple)

Directly after a restore using SD card. :-\

Also tried to remove the remote control dongle and use mouse for input. Same thing happens at the exact same place (Name your device). Maybe its related to the on-screen keyboard?

Does the fuzzy business also occur when using Confluence?

Can’t even get that far. That latest screen shot you are seeing is the “Setup”, just turning it on. It starts out in Confluence, then switches to the walkthrough which is in… the other one… (forgot the name).

Try touch /walkthrough_completed and see if it can complete startup.

Is that using SSH? Is there a good way to find the IP address of the device?

Yes in SSH. Check your router config to see what IP it has been assigned. Also note my edit to the location of the file. Should be in the root directory.

Switching to confluence seems to cause it to crash too. New log shortly.

Edit: Log File is

As a test @Guy can you try editing /etc/rc.local:

sudo nano /etc/rc.local

And before the line that says exit 0 insert a line that says:

echo 1 > /sys/class/graphics/fb1/blank

Save your changes (CTRL-X then y) then reboot.

Please let us know if this solves the graphical glitch issue for you.

No dice. Glitch still occurs after the edit of rc.local.

At this point I’m at a loss, and assuming the unit is defective in some way. I’ve sent a letter to support to see if a replacement makes sense.

Edit: I’m going to wait for a new update coming out which may help resolve the issue. I’ll post back when done.

The update has been released. Can you try it and report back please.

Looks like the update fixed the problem! Thanks for the help @DBMandrake and Sam!