Vero 2 dead?

#1

I think it’s dead. OSMC crashed last night - frozen video, stuttering sound - and my wife, not knowing what to do, turned off the screen and left it. Today, nothing. PSU is kicking out 5V but that’s all I can test. It’s not showing up on my network nor is there anything coming out of the hdmi port. I don’t remember if it has any lights on the outside of box but if there are they’re not coming on.

Any nifty ideas? This box is our daily driver for TV and has been rock solid the whole time we’ve had it (bought 16th Oct 2016). Dying now is non-ideal because we’ve just had a baby and as such are drastically short of both cash and time for fixing stuff. But if it’s dead it’s dead, I guess.

I know my way around linux systems so feel free to get as techie as you like.

0 Likes

#2

Hi,

I would try reinstalling, details can be found here:

Thanks Tom.

0 Likes

#3

OK, well that worked. Which I didn’t expect because it wasn’t even loading the bios a couple of hours ago.

So, just for kicks, I pulled the card and power cycled it before it started reinstalling and rebooted into the existing system. Works fine now.

Weird. I wonder if perhaps it had gone into thermal overload shutdown after being left in a crashed state for a few hours. I’m sure I’d powered it down for a few hours before trying again, but maybe I hadn’t.

Thanks for the advice, anyway. Working now so all good.

3 Likes

#4

It sounds like the internal storage on the device became corrupted. This could’ve occurred due to a power loss or unclean shutdown; or simply bad luck.

I’m glad it’s back up and running now.

0 Likes

#5

fwiw, I didn’t overwrite anything on the internal storage, just booted once from the SD card and rebooted before the countdown to overwriting had run down. My guess is this happened:

5am: system crashes. It’s left in this state for at least 6 hours. During this time of max cpu use, it gets hot and the hardware goes into thermal overload protection.
11am: I notice it’s not responding, power cycle a few times to no effect because it’s still too hot, but system is no longer running at 100% when I leave.
9pm: Without trying again, I post here.
10pm: boot from SD card into now-cool system. All is well.

What’s missing from that is me thinking that I’d tried once more on a system that is cool. Which is an oversight on my part, I should know better.

fwiw, I’ve never managed to damage an ext4 fs, even pulling power mid-write doesn’t seem to bother it…

0 Likes

#6

The device has thermal trip points to prevent damage to the hardware. Just make sure it’s not obstructed, i.e. anything on top of it.

You’re generally alright. We run an fsck on boot.

0 Likes