Vero 2 does not detect beamer when turned on

#1

Hi

I have a vero 2 and use it together with my Optoma H25 Beamer.
My problem is: when the beamer was in standby and i turn it on (while vero 2 is running), the beamer does not detect the vero 2 unless i do a reboot.

Do i really have to reboot the device every time i turn on the beamer?

i posted my logs here: http://paste.osmc.tv/gefujecuga

cheers,
Bendsch

0 Likes

#2

Try another HDMI cable

0 Likes

#3

i tried with another cable: same result …

0 Likes

#4

What has changed in your setup recently? Is this a new display?

HPD Lock would probably solve the problem, but it would mean there is an EDID handshake problem.

I’m not able to reproduce this issue with a Vero 2 on my own projector, so it would be good if you can confirm the above information. Your projector is advertising it’s preferred mode as 720p50 according to your logs.

0 Likes

#5

Nothing changed in my hardware setup. This problem existed since the beginning. It did not bother me since i allways did a shutdown after watching movies. Recently i started to use the Vero 2 as a music player (in addition to watching movies), so i prefer to have it running all the time.

The beamer can display 1080p, i don’t know what its preferred mode is though (and also not what that means).

What is HDP lock and how can i activate it?

Let me know if i can provide further information.

Cheers,
Bendsch

0 Likes

#6

Thanks for clarifying. I think this option exists on Vero 2 but don’t remember off the top of my head.

You can try:

echo hpd_lock1 | sudo tee /sys/class/amhdmitx/amhdmitx0/debug​

If this works, you can add it to rc.local to make it persistent

Sam

0 Likes

#7

thank you. i tried this but unfortunately it did not help.

while testing i noticed, that this only happens when the beamer is turned off during boot. sometimes turning on the beamer while the vero is already running even causes osmc to crash.
when i boot up vero while the beamer is on i can turn it off and on again as many times as i want and i get a picture.
could it be, that the beamer is being somehow “identified” during boot?

cheers, bendsch.

0 Likes

#8

Yes.

HPD lock in rc.local should do the trick to make this option persistent.
Did you try this?

Sam

0 Likes

#9

yes i tried (as mentioned above). my rc.local looks like this:

cat /etc/rc.local

#!/bin/sh -e

#rc.local

#This script is executed at the end of each multiuser runlevel.
#Make sure that the script will “exit 0” on success or any other
#value on error.

#In order to enable or disable this script just change the execution
#bits.

#By default this script does nothing.
/bin/echo hpd_lock1 | sudo /usr/bin/tee /sys/class/amhdmitx/amhdmitx0/debug
exit 0

this did not change the behaviour on boot (with beamer turned off).

0 Likes

#10

You don’t need sudo for rc.local

Can you repost logs as the old ones are no longer available?

Sam

0 Likes

#11

ok, eliminated sudo, rebooted and uploaded logs:
https://paste.osmc.tv/iyimuxahod

bendsch

0 Likes

#12

Sorry for the late reply.

I can confirm you’ve set the HPD lock setting correctly, and this is reflected in your logs.

Your display seems to suggest its recommended resolution is 720p50Hz.
I also have an HD25 and understand that the preferred mode is 1080p60Hz. Is there an AVR between things? 720p50hz is the fallback mode. You may need to wait for the projector to be turned on for a few seconds (after Optoma logo shows) before powering Vero.

It’s likely just a timing issue.

Sam

0 Likes

#13

the beamer is directly connected to the vero via HDMI.
my vero is running all the time as i use it as a transmission server and for listening to music as well.
so my standard situation for watching movies is: power on beamer with vero already running.

is there no solution for this?

cheers
bendsch

0 Likes

#14

Can you clarify if this is a new issue?
Presumably you’ve used Vero 2 on this display in the past without issues?

On the Vero 4K you can force a video mode by default but this is trickier on Vero 2. You should at least be getting 720p.

0 Likes

#15

no, its not new. it was bugging me for a long time and i somehow hoped it would be resolved in one or another update.

0 Likes

#16

i noticed that sometimes if osmc is already running when i turn the beamer on, i can still ssh into vero and also the chorus webinterface is rachable (and kodi is up and running), but still the beamer is not being recognized …

should this not be working ?!

0 Likes

#17

Thanks for clarifying this isn’t a new issue. We haven’t changed anything HDMI TX related for some time on the Vero 2.

The issue won’t be with the Vero itself; and you will find that it’s still on and responsive. The problem will be the distance between your Vero and projector, which causes some HPD problems.

When this happens, it would be interesting to know if:

sudo systemctl restart mediacenter brings back the picture
or if unplugging and replugging the HDMI cable at the Vero end helps

The issue doesn’t exist on the Vero 4K, but it has a different HDMI TX subsystem (HDMI 2.0); so it needs some thought about how to best approach this.

Thanks

Sam

0 Likes

#18

Hi Sam

Pluging out and in again the cable does not give me a picture on the beamer.

Also " sudo systemctl restart mediacenter" does not help.

MY HDMI cable is about 10 meters long.

cheers
bendsch

0 Likes

#19

Thanks for clarifying.
Do you get this with a short cable to the projector (if testing is possible); or using a different display?

I think increasing EDID timeout for long cables will probably work.

Sam

0 Likes

#20

i tested with a shorter HDMI cable (1m) with the same result. no picture if vero is already booted when turning on the beamer. unfortunately at the moment i have no possibility to test it with another display.

Bendsch

0 Likes