Vero 2 freezing (on black screen) when i click "stop" to exit a show/movie

Recently upgraded to a vero 2 from an rpi2 and either the latest version of osmc on the vero or the vero itself seems to have loads of bugs :frowning:

some (or most) are probably configuration changes that i am not aware of.

so the issues.

sometimes when i click stop to exit a show or movie it just freezes on a black screen or on the screen the show/movie was on. sometimes it will continue to the menu after 30 seconds other times it wont and i’ll have to switch the power to the vero off and on.

also, sometimes the sound just doesnt work on some shows/movies but is fine on others. i’ll reboot and its fine.

anybody experienced these?

Make sure you configured audio as per the quick start guide.

Post a debug log when you get a freeze.

1 hr into a movie and it starts stuttering and going slow Mo.

I pause it. When I click play it goes very fast for a few seconds to catch up then goes slow Mo again.

I click stop and it goes to black screen.

How do I get the log and post it? I’ve turned event logging on but when i check events it only has “osmc started up”

I just tried using the “log uploader” and it came back as

{“message”:“Document not found.”}

After a restart It froze up badly and came up saying cache full.

I went and got a spare Ethernet cable and plugged it in. that should solve that issue.

The audio seems to be the pass through playing up.

It was working, now its not. Audio works with pass through off.

I have the HDMI that comes with the vero 2 plugged into the TV and the TV has a S/PDIF from it to my home theatre.

should me audio be set to analog or s/pdif on osmc? assuming s/pdif.
because since the update, HDMI has actually dissapeared and the only options are analog and s/pdif.

besides that, the black screen freezes just seem to be severe lag. If i wait a while it comes back but its occuring constantly now and not sure why.

at this point i’m really thinking its the latest update not being stable. i wasnt really experiencing this freezing before the latest update.

Debug enabled logs would help a lot here.
Check if there is enough free space on the system partition.

If this were the issue there would be hundreds of reports on this forum. Please make another attempt to provide logs so we can remove the wild speculations from the conversation see what the true issue is.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

thanks heaps. i’ll try grabbing some logs for you tonight.

OK not sure if this will actually help or not.

Turned on debug log.

rebooted vero.

tried a few shows, the error wasnt popping up. (also, the audio passthrough is now working fine. go figure).

Tried a few movies, still no error.

turned the debug logging off (To remove text from screen) and got into a show and it froze up slightly when i clicked stop, only about a 5 second delay rather than the up to 5 minutes i’ve experienced previously.

so i’ve gotten the log for that. not sure if it’ll include it or not because i turned debug off, but havent rebooted since.

the log looks like its got some older stuff though so it might be in there.

http://paste.osmc.io/fomicexipu

You could leave the debugging on and just disable the onscreen if you want to test further.
Just activate debugging and change in advancedsettings.xml
<loglevel>2</loglevel> to <loglevel>1</loglevel>

Also, although I have pass through working again there’s no dts. My home theatre has dts hd btw.

Dts hd will not be passed through anyway. It will play the core stream then.
Do you have the dts options enabled in the audio menu?

how do i do that with putty?
i couldnt even find advancedsettings.xml in the location it states.

nano .kodi/userdata/advancedsettings.xml

[quote="mcobit]Dts hd will not be passed through anyway. It will play the core stream then.
Do you have the dts options enabled in the audio menu?[/quote]

i’ve tried with passthroug enabled and DTS on, and with DTS off and 8 channel DTS-HD on. neither work.

main difference i can see is the rpi input was set to HDMI whilst the vero only has analog and s/pdif. I’ve got it set to s/pdif.

just got it again (debugging not on).

http://paste.osmc.io/otemuzumac

started the movie the game and exited it (clicked stop) and got a 60-120 second black screen.

around 8:20-8:35pm

maybe not related to your problem but suggest to check your network.
What does wget https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5 executed on the Vero gives you?

osmc@vero:~$ wget https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5
converted ‘https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5’ (ANSI_X3.4-1968) -> ‘https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5’ (UTF-8)
–2016-10-18 21:10:42-- https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5
Resolving github.com (github.com)… 192.30.253.113
Connecting to github.com (github.com)|192.30.253.113|:443… connected.
HTTP request sent, awaiting response… 302 Found
Location: https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5 [following]
converted ‘https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5’ (ANSI_X3.4-1968) -> ‘https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5’ (UTF-8)
–2016-10-18 21:10:43-- https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.100.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.100.133|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 32 [text/plain]
Saving to: ‘addons.xml.md5’

addons.xml.md5 100%[=====================>] 32 --.-KB/s in 0s

2016-10-18 21:10:43 (1.80 MB/s) - ‘addons.xml.md5’ saved [32/32]

Seems intermediate network problems. Suggest to have a longer term iperf running between your Vero and your samba server.

its a wired connection direct to my router and my pc is wired too. not sure why i’d be having network problems, i didnt with the rpi2.

How do i run an iperf between vero and my pc (smb server).

once i’ve done that as its a new file, is the only line i need to write in there
1

is there further text needed? sorry i’m a novice linux user