Vero 2 freezing (on black screen) when i click "stop" to exit a show/movie

osmc@vero:~$ wget https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5
converted ‘https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5’ (ANSI_X3.4-1968) -> ‘https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5’ (UTF-8)
–2016-10-18 21:10:42-- https://github.com/popcornmix/repository.popcornmix.storage/raw/master/addons.xml.md5
Resolving github.com (github.com)… 192.30.253.113
Connecting to github.com (github.com)|192.30.253.113|:443… connected.
HTTP request sent, awaiting response… 302 Found
Location: https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5 [following]
converted ‘https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5’ (ANSI_X3.4-1968) -> ‘https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5’ (UTF-8)
–2016-10-18 21:10:43-- https://raw.githubusercontent.com/popcornmix/repository.popcornmix.storage/master/addons.xml.md5
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.100.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.100.133|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 32 [text/plain]
Saving to: ‘addons.xml.md5’

addons.xml.md5 100%[=====================>] 32 --.-KB/s in 0s

2016-10-18 21:10:43 (1.80 MB/s) - ‘addons.xml.md5’ saved [32/32]

Seems intermediate network problems. Suggest to have a longer term iperf running between your Vero and your samba server.

its a wired connection direct to my router and my pc is wired too. not sure why i’d be having network problems, i didnt with the rpi2.

How do i run an iperf between vero and my pc (smb server).

once i’ve done that as its a new file, is the only line i need to write in there
1

is there further text needed? sorry i’m a novice linux user

<advancedsettings>
    <loglevel>2</loglevel> <!-- Change this to "1" to hide the on-screen debug log text -->
</advancedsettings>

http://kodi.wiki/view/Log_file/Advanced

Install iperf sudo apt-get install iperf3 and run it with iperf3 -c <SERVER IP> (on the client) and iperf3 -s (on the server). The installation on your PC depends on the OS you have.

i’ve got windows 10 (anniversary edition).

so does the iperf run in the background or is it a test i need to leave running by itself for a while?

https://iperf.fr/iperf-download.php

It’s not a daemon running in the background, so yes you need to keep the window with it running open.
You can influence how long the test runs with the -t option on the client side

http://paste.osmc.io/vumubuxiya

Debug log. This weekend whilst trying to watch marvel agents of shield. I think around 1:19 or so was when I had it freeze again.

It’s pretty constant.

Also the ui keeps getting stuck on the screen too.

Can you try copy the file to a local storage, like a USB drive and playing it?

Does sudo systemctl restart mediacenter fix Kodi freezing, or do you need to fully reboot?

http://paste.osmc.io/ixawiteniz

Da Vinci’s demons at 11:06 the ui froze on the screen again for a while.

I don’t technically have to restart the vero. It continues after some delay.

Sometimes it’s short other times its 5 minutes.

I switch the power off and on when I become impatient.

The freeze isn’t just stopping too. Like I might skip forward 30 seconds and the top bar of the ui stays on the screen.

I click OK and pause and play and then that entire ui screen stays on the screen.

Sometimes the ui stuck overlap.

Could it be an unstable skin build?

My rpi had an older version of amber cause there seems a few differences with this.

Start with Confluence and disable add-ons

Try a local playback,

It’s just frozen the ui on confluence. Took 4 minutes to exit the in video audio settings screen.

Have you disabled all other add-ons, and tried playing back content locally?

Will try now.

Including audio encoders? Scrapers etc?

It is not clear which customisations are made on your system. The easiest way to rule out software issues are to download and install a fresh version of OSMC.

The vero is brand new.

The only thing I’ve put on it is the amber skin

No video, picture, movie add ons.
The only program add ons are my osmc and boot to Android.

Switch to Confluence and reboot

Try and play back a local video file; so far you have been trying to play back content from the network.

Ok ill reboot and play back a local file

Was still happening locally prior to a reboot.

Ive just rebooted and playing locally now. Problem is it’s usually fine after a reboot for a little until it’s not. I’ll keep you posted.