Vero 2 - Getting CEC error from my TV since latest update

Since the last update, my TV keeps popping up with a CEC error. The only way to stop it is to pull out the HDMI cable from the Vero 2. I’ve even swapped out the HDMI cable and same issue. Have also tried disabling CEC adapter but no joy. Any ideas?


Did it work before the update? Do you remember what version you were on before?

Can you describe your setup? Do you have an AV receiver? What make and model? Same for your TV.



It worked fine before the April update. I was running the version released in March. I have an av amp which it’s connected to via hdmi. I tried swapping inputs but same issue. I have Pioneer amp, think it’s VSX 920 but will check later, and Pioneer Kuro 428 plasma TV.

A debug log should help us find the issue.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Also try powering the TV off at the mains for few minutes


Hi Sam,

I got home this evening and it seems to be behaving itself. If it happens again i’ll enable debugging and chuck you over the logs.