Vero 2 - No internet/No Wifi/No audio


I have just received my new vero 2 and I was quite excited. I have plugged it to my projector. But:

  • audio (through hdmi) is not working
  • no wifi configuration possible (not in the list)
  • plugged into ethernet, my NAS is accessible but no internet (updates not working and update library either)

I have tried to reinstall OSMC, but not better (maybe worse because now i have sometime a screen with a sad smiley coming up from time to time)

And finally @sam_nazarko, you forgot to include the bluetooth receiver as promised :wink:

So I would be quite grateful if I could some help here :slightly_smiling:


Search re. Updates
You need to update for WiFi to work
You need to configure audio in Settings. Some audio fixes will come in the update and should resolve your issue

We included Bluetooth dongles for all customers that ordered them. We included a couple free of charge to those that requested them, but cannot do this for everyone as we ran out, so they needed to go to customers that explicitly ordered them


The connection to internet is not working even ethernet correctly working which is not Normal since all my other devices are connected correctly. So I cannot upgrade.
Concerning the Bluetooth dongle, I was among the ones you promise to offer one…
For the audio I did not find how to set it up in the menu.

Are you saying you cannot connect via Ethernet to perform an initial upgrade?

Please send me your order #, I sincerely apologise if you purchased a Bluetooth dongle and did not receive one and if this is the case will ship you one immediately. We ran out of complementary dongles to ship to customers, as everyone seemed to request a dongle when ordering, but we did not realise this until we got to fulfilling orders


I connect my Ethernet cable. I have access to my LAN ( my nas is accessible) but for an unknown reason, I cannot access internet.

Concerning the dongle, you offered to send me one (you can check it in our mail exchanges )

I don’t see the dongle on your order number. I do apologise if you did order a dongle. Let me know if something is wrong there. For now we do not have any, but we should get some soon.

When you say you cannot access the Internet, how are you reaching this assumption?

3 use cases made me realize that internet access was not working:
-trying to get updates: “Add-on Error”
-when adding a folder from my NAS, OSMC try to get information from themoviedb. I get an error telling me that it cannot access it.
-Network menu: It says connected (IP correctly assigned) but no internet.

I did not have the time to ssh to the vero and do a ping or traceroute but there is clearly something wrong in the network configuration here.

And this is not coming from my LAN setup which is quite standard and working perfecty with other devices (example RPi2 with volumio with the same cable !!)

Saying connected can simply mean ConnMan is unable to reach a WISPR, and is not a reliable indicator of the connectivity status

The Movie DB scraper has been problematic for some time now and certainly needs an addon update. You may need to refresh your addon repo

Updates will work again as it is no longer the 29th

I will try again tonight but I did try to change the timezone as a workaournd.
I will keep you informed.

The updates work today and the add-on error is gone. But I have the same issue with the movie database. Works just fine on a PC, but not on Vero.

I think there have been some issues with The Movie DB add-on lately. Does using an alternative scraper like IMDB work as a test?


I tried to change it to something else but I probably need to install the IMDB add-on first and I cannot understand how to do that. I go into “More” and then it leads me into some directories where I have no idea where to find an installation “link”.

Edit: Ah yes, now I remember - I also cannot access the Kodi add-on repository. When I go to System>Dependencies I can see the IMDB Scraper Library is enabled, but I cannot change from Movie DB to IMDB as the info source.
I’m not sure I’m properly connected to the Internet though the updates seem to be running.

pierreb, sorry I’m using your topic, but I’d guess you have the same issues.

I am quite okay with you using my topic :slight_smile: I am hoping you will find the solution so I can test it tonight :slight_smile:

Thanks! :slight_smile: My topic is here Vero 2 not really usable so far - #6 by Kato
Do you have something similar?

It would be good to keep your issues in a separate thread guys, I’m getting a bit confused.


It seems that the issue Kato is facing about connection is the same as me, so we could converge to his topic.
Would that be alright with you ?

Sure – but the issue may not be related.


Good news ! I was able to perform the update and now everything is working properly.
Last thing for me is to understand how to make 3D movies (HSBS,…) work properly with my DLP-Link projector…

I didn’t realise we could all request a complimentary Bluetooth dongle. I did see you offer one to a poster who asked if Bluetooth is built in but I assumed it was a one off and didn’t have the cheek to ask myself.

I have an ancient one but it locked out my OSMC remote when plugged in so the Vero 2 was only controllable via the TV remote. Rebooting with the dongle brought up many lines of instructions so I rebooted again and ditched the dongle. Googling “BlueNext” I believe it may be Windows only.

If you’ve run out I’ll grab one on eBay, should any of them work?