Vero 2 seems to disrupt my ADSL modem/wifi router

This is weird; I hope you can help…

When my Vero 2 is on, the connectivity though the wifi router it uses (which is also the ADSL router for everything else as well) slows down from ~3.5Mbps to not being able to run a speedtest (although web pages occasionally load, if I’m patient).

For clarity: This is not about slow wifi to a media server - it’s my Internet connection not working properly when the Vero 2 is on.

I initially assumed this was a problem with my ISP’s service, but eventually noticed that only happens when the Vero 2 is on. This happened over a month ago - possibly more than two months. It seemed to work fine when I first got it.

To replicate:

  • Have my Vero 2.
  • Have my modem/router (Thomson TG585 Gateway v8, firmware
  • Switch them on.
  • Find that the Internet appears to barely work.

I’ve tried blacklisting the wifi module (8189es), but that makes no difference.

What peripherals:

  • Vero remote USB dongle
  • USB 3 HDD (WD 3TB My Passport Ultra WDBBKD0030BBK-EESN)
  • USB wired keyboard (whilst blacklisting the wifi module)

For testing I unplugged everything, and the problem was still there.

Most bizarrely, when I shut down OSMC it doesn’t power down the Vero 2, the disruption continues until I switch it off at the wall.


An unusual problem :frowning:


Start-Date: 2016-08-25  21:53:46
Commandline: apt-get upgrade
Upgrade: libgcrypt20:armhf (1.6.3-2+deb8u1, 1.6.3-2+deb8u2), gnupg:armhf (1.4.18-7+deb8u1, 1.4.18-7+deb8u2), gpgv:armhf (1.4.18-7+deb8u1, 1.4.18-7+deb8u2)
End-Date: 2016-08-25  21:53:52

Never run apt-get upgrade, only apt-get dist-upgrade.

So far as I recall, if it returns with no packages kept back (which there aren’t, I ran a dist-upgrade just now to double-check) there’s no functional difference. Or is there something else a dist-upgrade does?


The dist-upgrade brings in meta packages and new dependencies, a regular upgrade does not. If you run apt-get upgrade, you will have to reinstall your system for correct functionality again. This is covered in the Wiki.

Your question is a bit vague. How do you determine the internet ‘barely’ works? Are you running a custom DHCP or DNS server on your network?

I’m struggling to see how you’d get network performance problems even when Vero 2’s network connection is disable (blacklisted WiFi). Make sure you don’t have anything like a torrent client running on Vero 2.

Also consider installing iftop and running that. It will show you quickly if the Vero 2 is sending a lot of traffic across the network. A freshly installed one won’t be though.

Well, to remove any doubt I started re-installing OSMC from SD card.

However, I didn’t need to complete installation to replicate the problem - just having it turned on (waiting at the installer’s language selector) replicated the problem.

From this I’m guessing it’s a hardware problem.

No custom DHCP or DNS.

“Barely works” as in: when Vero 2 is off, rates my connection as ~3.5Mbps - when switched on can load the page, but can’t complete the test.

During previous testing it seemed like the USB keyboard worked ok on one port, but only intermittently on another (wouldn’t reliably get key presses/releases).

It seems like a USB 3 HDD might take a lot of power - might that have too much for the Vero 2 to handle?


Edit to clarify: Just one USB3 HDD, not three HDD all plugged at the same time.

For correct operation of your device, you will definitely want to reinstall OSMC after running sudo apt-get upgrade, as this can cause problems.

The thing is, I really don’t see how. If you have Wireshark or tcpdump, you can see what the Vero 2 is sending on your network. I can’t envisage a situation where it would cause network issues, and we would need a bit more to go on to investigate this.

Not sure what that actually means, but I would check the usual suspects (ARP, nslookup etc).

Keyboard or remote should go in the rear port only

3 HDD will be too much for the original PSU, but you can use a higher amperage 5V PSU (5.5 outer, 2.1 inner) barrel jack PSU, and you should be good.

Here’s how I see it:

  1. When switched off, the network is fine, with a download rate around 3.5Mbps.
  2. When switched on - without even attempting to join the wireless network or getting an IP address - the network can barely manage 0.2Mbps d/l (guessing from a partial test).

I had Wireshark listen on the wlan, but couldn’t see anything obviously from the Vero 2. I’ll have to learn more about Wireshark and get back to you.

Sorry, I shouldn’t have assumed that you would know what that is; is a browser-based bandwidth tester that downloads progressively larger chunks of data to estimate the speed of one’s connection. The test loads in the browser and can be started (so DNS seems to work), but connection is so slow that it can’t load any of the chunks, so fails.

Any pointers on what checks to make - and how? (I’m not a networking admin.)

Sorry, that was a typo on my part - it was one HDD with a USB3 connector.


I realise this reply is somewhat late but I’ve only just joined the forum and read this thread.

If WiFi throughput on other connected devices is severely affected when the Vero device is merely powered up but not using WiFi itself (because its WiFi module is blacklisted), I’d strongly suspect a faulty power supply.

I’ve not seen a Vero 2 (I’ve just ordered one) but I suspect that its power supply is switched mode. Poor design of such units (a general comment - not directed at the Vero power supply) or a manufacturing fault can result in extremely high levels of very wideband radio interference. If this is happening here, a high RF noise field can easily degrade WiFi performance.

To test, try moving a portable AM radio that’s tuned to noise between stations around the area where the Vero power supply is located and see if the noise level increases. Also try plugging in the Vero further away from the router and, ideally, try a different power supply on the Vero.

It’s quite possible that a problematic power supply isn’t the cause of the effect described, but I can’t think of anything else off-hand that fits the symptoms.

Funnily enough, this happened to me with my desktop. There is an issue with USB3 devices interfering with some WiFi channels. Log into your router and select another channel (anything over 6 should be fine IIRC).

If the hdd has a powersupply, it could also be the cause of the problem if the switching causes rf interference with the wifi signal.