Vero 2 - slow wifi


I’ve just started using my new Vero 2 and am noticing the onboard wifi being very slow to access media files over the local network.

I had an initial problem with the onboard wifi not being recognised but that seemed to be sorted out by an update.

I have media stored on a NAS and am accessing it over SMB. An example is trying to play back a 1080 .mp4 which takes between 15 and 25 seconds to start.

As a comparison, I also have a Netgear ethernet > wifi adapter available which I use to hook up my satellite box to my network. Plugging the Vero 2 into this adapter (so still connecting to the share over wifi) results in the example above taking 2 seconds to begin playback.

My paste is here:


For some background, can you let us know the file size of the 1080p MP4? SMB can have a fair bit of overhead, but it shouldn’t take this long for a video to start.

Can you try something like an Apple iTunes trailer to see if that takes a while too?

Also: next month I will disable power management by default for WiFi, as it causes some performance penalties. This command (temporary, just to test) may help:

sudo iwconfig wlan0 power off


Thanks Sam,

The size of the playback file in the paste is 1.61GB. It is a h.264 / AAC 1920 x 816 file.

Another test with a standard def .avi file actually times out over the built-in wifi but plays ok using the external adapter mentioned above.

I’ll try your suggestions later on this evening and report back.


Tried the terminal command, got the following reply after installing wireless-tools via apt-get:

osmc@osmc:~$ sudo iwconfig wlan0 power off
Error for wireless request “Set Power Management” (8B2C) :
SET failed on device wlan0 ; Operation not permitted.

I’ve just tried the Apple trailers and they seem to start playing almost instantly. The playback stop/starts as it looks like the internal wifi is struggling to buffer fast enough. I tried the same with my external wifi adapter as mentioned above and this seems to solve the issue.



Try running iwconfig wlan0 and copy the output here. It will be interesting to see the established link speed.

How far are you from the router?

I am getting about 35Mbits from upstairs, which is good enough to stream 1080p content quite smoothly.

The power saving fix will come in the next update, and that should give you some improvements too.


I’m pretty close to the wifi router. The Vero is in the living room, the router is in the hallway, up high about 5 meters away behind a solid brick/block wall. The below is what I got with iwconfig wlan0:

Mode:Managed Frequency:2.437 GHz Access Point: AC:22:0B:31:E0:C0
Bit Rate:150 Mb/s Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=100/100 Signal level=-45 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

150 Mb/s is not bad I’d say?

I’d like to try a common external wifi adapter to see if I can work around this issue. I have an Edimax EW-7811un which I use with a couple of RPis running Raspbmc.

I’m a bit of a beginner at all this. It doesn’t power up, show up in the wifi config GUI or in ifconfig either. Can someone help?

Ok, not much in the way of replies here…

I’m getting to the point where my only assumption is that I have a defective unit, and that I will have to request a replacement.

The internal wifi on my Vero 2 seems unreasonably slow. It seems the Vero 2 is unable to stream media over wifi at a decent speed, causing video to take a long time to start playing, and then having buffereing issues during playback.

It doesn’t seem to be a signal strength issue as the GUI shows a strong signal. My router is very close to the Vero 2. Also, using an external Netgear wifi > ethernet bridge into the Vero 2 solves all issues. No buffering and playback starts almost immediately.

I have also tried setting up a new access point in my home using a spare router that I had lying around. This does not solve the issue.

Interestingly, mkv files start playback after a couple of seconds, but then faces an immediate and regular buffering delays. Other media files take up to 20s to start playback.

The media is being served from a NAS via SMB, but I also have the same issues using SFTP.

*** edit**

Just read back over the thread - apologies Sam, you said you’d issue a wifi power management fix this month. Guess I need to wait for that and see if it solves things.

I see no mention of you trying standard Wifi troubleshooting procedures, such as changing the channel on your Wifi router to one with a minimum of other AP’s on it - you may be getting interference from other wireless routers or devices.

Keep in mind that the Vero 2 wifi is 2.4Ghz only, so if you have a dual band router many or most of your other devices like phones/laptops etc might be using 5Ghz. So if there was an interference issue on the 2.4Ghz channel it would not be noticed on devices that are connecting on 5Ghz.

Another thing you could do is run a network throughput test using iperf - you can install it with sudo apt-get install iperf and then test to another (preferably hardwired) PC on the network - versions of iperf are available for Windows, Mac and Linux, although it is a command line only program.

Performing a speed measurement like this on different channels may identify whether there is an interference issue or not and what channel might give you the best results.

At the end of the day, a wireless device can only perform within the constraints that are imposed on it by the router and any other nearby devices that use the same frequencies, and unfortunately sometimes wireless troubleshooting can involve a lot of trial and error to track down what within an environment is the cause of poor performance.

I have no trouble playing back content up to about 30Mbps on mine over Wifi.

I have not done any wifi troubleshooting procedures, as first of all it was not suggested, and second of all in my eyes I have eliminated signal problems being the issue as I get no such problems with the Netgear wifi > ethernet adapter detailed above. This adapter sits next to the Vero 2 and connects to my dual-band router on the 2.4GHz band, just as the Vero 2 would. I have also tried a different access point (detailed above) which was on a different channel.

My router is dual band (Asus RTN66U), but 90% of the devices in my home connect to it on the 2.4GHz band without issue.

Here is my iperf result. OSMC wifi > router < ethernet client:

osmc@osmc:~$ iperf -c
Client connecting to, TCP port 5001
TCP window size: 20.7 KByte (default)
[  3] local port 43171 connected with port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  48.1 MBytes  40.1 Mbits/sec

40.1Mbit/sec seems fine to me, and is about what I get on mine with an iPerf test. As the wifi chip has a maximum wireless rate of 65/72Mbps (depending on your AP’s mode) 40Mbps actual throughput is about right.

One thing to be aware of though is the test you just ran tested the sending performance of the Vero not receiving, which is what you would be using when streaming a movie from your NAS.

It might seem strange but when you test with iperf the server (-s option) is the one that receives data and the client (-c) is the one that sends, which is opposite to what you would expect.

So to test download/receiving performance to the Vero run the iperf server on the vero and the client at the other end. (Just reverse the options) If you get around 35-40Mbps there as well then I think we can rule out wifi throughput as the issue unless you are playing full bit-rate blu-ray rips, which would not be able to play over Wireless at this speed, as they can go as high as 50Mbps. Most “standard” rips are well under 20Mbps though.

You say you are using SMB - are you using the SMB client built into Kodi (smb:// URL in the video path) or are you using a kernel mount ? (a CIFS mount in /etc/fstab mounting to a directory, then referring to that “local” directory in the video path in Kodi)

Have you tried using NFS and/or using a kernel mount for SMB or NFS ? Most NAS boxes will support NFS and it is generally considered to be a leaner faster solution for streaming media than NFS, and mounting remote file systems via kernel mounts can often be significantly faster than using Kodi’s built in SMB and NFS support.

I have noticed some odd behaviour with Kodi’s inbuilt NFS client in Jarvis that I’m still investigating - which is causing the occasional pause for about 1 second while streaming from my NFS server even over Ethernet. If I switch to kernel NFS mounts the problem goes away. I wonder if you are seeing something similar.

Here is the kernel mode NFS mount I am using in /etc/fstab as an example: /mnt/Mac-Mini nfs noatime,noauto,x-systemd.automount,async,nfsvers=3,rsize=8192,wsize=8192,nolock,nofail,local_lock=all,soft,retrans=2,tcp 0 0

I previously created the mount point for it with sudo mkdir /mnt/Mac-Mini

Thanks for your help with this. Here are my results with the client/server reversed:

osmc@osmc:~$ iperf -s
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
[  4] local port 5001 connected with port 55296
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.4 sec  13.1 MBytes  10.6 Mbits/sec

So 10.6 Mb/s is significantly lower…

I am using the usual smb:// mounts in Kodi rather than anything fancy with the Kernel (bit beyond my capabilities at the moment, but I’m learning!).

I think my NAS does support NFS, but it bothers me that regular smb shares work fine when not using the Vero’s internal wifi.

I’ll have a look at NFS in the meantime, but the d/l speed detailed above is a red flag isn’t it?

Yes, 10Mbps receiving is too slow, especially when sending was about 40Mbps. It’s unusual for send and receive rates to be that lopsided.

That would be slow enough to cause issues with many HD videos and the kernel mounts would not help there.

So am I looking at a software / driver issue, or possibly a hardware one? I’m guessing it’s quite difficult to diagnose.

Did you try and disable the power saving? Alternatively, did you update to the latest software which disables power saving

The power saving command that you gave me initially didn’t work Sam. I am on the latest software as of today. The results that I have posted today are all on the latest OSMC update.

Wifi performance issues can be difficult to diagnose, yes.

Given that the speed between sending and receiving is so different I would try disabling backwards compatibility with B and G wireless devices. (Assuming all your devices are N or AC which most are these days)

On my Superhub 2 the settings to do this are to disable OBSS mode and to turn “Greenfield mode” on. Some other routers may let you disable B/G modes some other way.

I would also try a few different channels and on each one reset to the slow receive speed.

Ok, I have spent the day running lot of iperf tests. I did this by running iperf -s on OSMC, and using a separate machine connected to my home network via Ethernet to run iperf -c.

I went through each of the 13 Wifi channels on the 2.4GHz band and ran a test in each. These tests were all run with b/g protection disabled. To double-check I also ran a few of the tests with protection enabled.

The maximum speed that I was able to establish to the Vero 2 was 8.06 Mb/s:

osmc@osmc:~$ iperf -s
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
[  4] local port 5001 connected with port 57410
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.3 sec  9.88 MBytes  8.06 Mbits/sec

I also ran a different test with the Vero 2 in a different position in the house (closer to the router) and got similar results.

I then tried swapping the PSU to a branded one that I had spare, tried with the remote control dongle unplugged and also tried headless and plugged into a different monitor, all without significant effect on the iperf results.

Finally, I tried connecting to a different access point that I have spare - no significant change in the result.

Finally for balance, here is the iperf result that I’m getting when disabling the Vero’s internal Wifi, and using a Netgear Ethernet > Wifi adapter. So, still Wifi as far as my home network goes, but Ethernet as far as the Vero is concerned:

osmc@osmc:~$ iperf -s
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
[  4] local port 5001 connected with port 53832
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.1 sec  80.9 MBytes  67.5 Mbits/sec