Vero 2 won't boot (hardware issue?)

My Vero 2 which I received in April stopped working / booting last month. Upon startup the blue LED lights up but nothing is displayed on the screen and boot seeming won’t progress at all. To avoid violating warranty, I put the installer on a separate (external) SD card and tried to power up / reinstall the box with it, to no avail. Seemingly nothing happens.

What should I do? Send the hardware back and initiate an RMA? Am I still under warranty?

What were you doing with the device when it last stopped working? You should let us know of an issue at the earliest possible opportunity.

Provided the device hasn’t been tampered with / opened / used with the wrong PSU etc, it’s under warranty.

Better to try some troubleshooting steps first.

  • Can you boot in to Recovery? This can be accessed by applying a toothpick to the rear audio port nearest the USB port during boot. You should hear a soft click.
  • After flashing your SD card with OSMC for Vero 2, try renaming kernel.img to recovery.img and see if this helps.


The correct port is actually the one nearest the HDMI connector. :slight_smile: In any case, only one port has a small switch that will click when you push a toothpick into it.

Hey guys,

Thank you for the prompt reply!

The device has not been opened or tampered with. It’s stock/vanilla Vero 2. Software updates are enabled on it. Before I noticed the issue the box was rebooted but I don’t recall seeing anything odd. It literally just wouldn’t start one day.

I just tried to boot it with the recovery switch pressed (it was indeed in the audio port next to the HDMI). I have not noticed anything different. I assume this means that the issue happens in the early phase of the (hardware) boot. The TV doesn’t say that there is no HDMI connected but there is a blank screen. The blue LED never turns off but that’s the only sign of “activity”.

LMK what else you would like me to try!


When you booted with the recovery switch held down, did you have the SD card with the OSMC installer inserted, which has the file kernel.img renamed as recovery.img as Sam described earlier ? Also make sure you hold down that button for at least 30 seconds after connecting the power.

If you have no SD card inserted (or recovery.img does not exist on the card) it will try to boot from a recovery partition on the built in nand storage, however when recovery.img is present on the SD card it will try to boot that instead.

Thanks guys, indeed, I managed to reinstall OSMC with these instructions from the SD card! So looks like it indeed was a software issue in the end.

Just to conclude, in case others stumble upon this (hardware instructions are for Vero 2):

  • see if you can recover from the built in partition by pressing the recovery switch in the audio port right next to the HDMI port
  • if recovery isn’t triggered, create an SD card with the OSMC installer (I used the img and dd)
  • rename kernel.img to recovery.img on the SSD card
  • insert the SD card into Vero 2 and attempt recovery boot by pressing the recovery switch in the audio port during boot

Latter kicked off the boot properly for me and I was able to (re)install OSMC on /dev/osmc-nand (or whatever the NAND device was named).

Thanks again guys for all your help!