Vero 4K+ and AV Receiver video issue

Hello Everyone,

My old receiver died and I got a new one. The model is a Yamaha TSR-700, which is the same as the RX-V6A. The rebrand is because of an agreement between Yamaha and the retail store chain.

My old receiver did not process video, so I connected the Vero 4K+ directly to the TV via HDMI and to the receiver via the digital optical port. Everything worked great.

With the new AV receiver, I connected the Vero 4K+ to one of its HDMI ports and the receiver to the TV via their HDMI ARC ports.

I can play some videos fine. However, others simply blank the screen and also kill the audio. Only way to get the Kodi UI back on the TV screen is by pressing the Stop button the Vero’s remote, turning the receiver off and then on again. The videos doing this are 1080p in MP4 or MKV format. Even some videos that I got by ripping my BluRay disks using MakeMKV have this issue and all played fine with the Vero connected directly to the TV.

All my content is 1080p or DVD-resolution, and some YouTube and Netflix videos at 1080p or lower.

The receiver has a “4K Upscale” option but I kept it disabled because my TV is not 4K.

Another weird thing is that the screen calibration also gets reset when I play a video through the receiver. I go to the Kodi’s overscan calibration, set the corner arrows, closed caption height and 1:1 box, and it plays the the first video well but when I start a new one, all calibration goes away. This never happened when the Vero was connected directly to the TV.

I then reconnected the Vero 4K+ back directly to the TV and all problems went away, including the overscan reset issue. Therefore, now it is connected to the receiver like with the old one (via digital optical), Vero 4K+ to TV, and the receiver to the TV through the HSMI ARC. But the TV is set to read the input from the HDMI port where the Vero is connected.

So, based on the tests, it appears that there’s some configuration on the receiver that I am missing. Or, maybe I need to change something in the Vero 4K+ (Kodi or OSMC?) to make it work well through the receiver?

Did anyone else experience similar issue, and how was it resolved?

Thanks much in advance!


It seems you have a issue with Overscan. Ensure that you did not have any calibration configuration in Kodi/OSMC and use one of the following methods depending on the TV Brand you use.

  • Samsung TV - go to Menu / Picture / Picture Options / Size / Screen Fit (instead of 16:9).
  • LG TV - go to Settings / Picture / Aspect Ratio / Just Scan (instead of 16:9)
  • Sony TV - hit Home button, go to Settings / Screen / Display Area / Full Pixel
  • Sharp TV - hit View Mode button, select “Dot by Dot” or “Full screen”
  • Sharp Aquos - go to Menu / System Options / View Option / View Mode / Dot by Dot
  • Panasonic TV - go to Menu / Picture / Screen Settings / 16:9 Overscan / Off

Thanks Tom.

Thanks Tom!

The audio is working fine. Actually, I can hear the audio playing before the receiver “goes blank” (no image and sound) and only shows the Kodi’s UI again after I turn the receiver off and then on again.

Yep. That’s how it’s setup on the TV and it works fine when the Vero 4K+ is connected directly. I only had to adjust the screen calibration once in Kodi and it worked fine since then.

However, if I make the video signal go through the receiver, this calibration seems to get lost. Meaning that I calibrate Kodi’s screen again, but after playing a movie that calibration gets lost. I don’t know how the receiver is impacting Kodi’s calibration.

Today I replaced the HDMI cables with new ones rated for 4K/UHD/18GBPS. The whole shabang. Still no go.

I then played one of the disks I ripped in the BD player and it played without issues. Again, it’s a 1080p standard BluRay disk. No 4K, HDR, etc.

So, whatever is happening, it is something in the Vero 4K+'s video signal that the receiver cannot decode, even through the TV can go is without any issues.

I tested this again by checking one of the ripped disks that did not play through the receiver but played without issues when I reconnected the Vero 4K+ directly to the TV again.

I also tested again playing 1080- videos downloaded from YouTube and from Netflix. The 1080p from YouTube played. The 1080p downloaded from Netflix did not.

So, in a nutshell:
Vero 4K+ > TV : no issues
Vero 4K+ > receiver > TV : some videos in 1080p do not play.

I wonder if there’s anything I can check in the videos’ encoding that could be causing the confusion in the receiver but not the TV?

Thanks again!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

You might check this as well into the rx-v6a

Each resolution has it’s own calibration settings, so eg 1080p60 is different from 1080p59.9. The whole calibration thing is a PITA. If you have a look in ~/.kodi/userdata/guisettings.xml you can see the values and re-set them quickly. systemctl stop mediacenter first.

Hello Tom,
How do you recommend that I run the test? Meaning, does it make a difference whether the Vero 4K+ is connected to the TV or the receiver to run the files?
I thought about running a couple video files that work and a couple that fail.

Hi mtv,
Yep. I tried both video modes (1 and 2) and both fail.

However, on a side note, I am not trying to play 4K content, since my TV does not support it. Everything is 1080p or below.


Please produce logs showing the blank screen, when connected to the AVR.

Thanks Tom.

Found the problem!!! :smiley:

A friend of mine told me to check the receiver’s firmware version. Despite brand new they can come with old versions.

Lo and behold, the receiver’s factory firmware was 1.36. And Yamaha’s latest version was 1.48!

I updated the receiver’s firmware and now it plays the problematic files without any issues. So, conclusion, always check the stuff for updates. :stuck_out_tongue_winking_eye:

One last thing. The TV’s screen is set as recommended by the instructions: “screen fit”

However, Kodi’s UI still has a bit of overscan. But, when I play the movie, it seems to correct and adjust itself to the correct size.

Is this expected?

Thanks much for all the help!

1 Like


Yes, it is my understanding overscan only effects the gui and this would tally with I’ve seen on my LG TV.

Thanks Tom.

Did you removed all video calibrations on Kodi?

1 Like

This is good to hear.

I guess so. I tried a lot of stuff and in the end decided to leave it as is, since it isn’t much of a hassle, since the videos play quite well.

The Vero 4K+ is a great little device. I promote it whenever I have the opportunity. :grinning:

1 Like