Vero 4K and Dolby Atmos/DTS:X

#1

Hi guys!
I updated my home cinema with Atmos speakers. Now I tried to get some trailers to hear my new cinema sound with my Denon x4200 - won´t work.
I get no atmos or DTS:X Signal from the Vero to my AVR. I also tried to play the files via my PC (VLC) to my AVR - everything works.
I´m on it a few hours but can´t get this issue solved. Can anyone help me in this case why I get no Atmos via Vero 4K to my AVR?

PS: I´m on the latest FW.

Atmos
#2

Did it work before the most recent update? There were some changes there.
Did you configure audio correctly to enable passthrough; and do other formats work correctly?

Sam

#3

Sure. I made the latest update. My AVR plays “only” 7.1 Multichannel. Also when I play TrueHD it also displays “PCM” 7.1 Multichannel.
Only via Vero 4K, with my PC there is always displayed the correct sound format.
I think I tried each config…

#4

Hi,

Can you clarify

Are you saying it doesn’t support HD audio passthrough? This is required for Atmos to work.

You can enable DTS TrueHD passthrough in Kodi settings provided that your
amp supports it. TrueHD can be decoded losslessly and streamed as LPCM, which
is why it works with passthrough disabled. Atmos cannot; which is why we pass it through
to the AVR (the way it’s meant to be done for best audio quality anyway)

Sam

#5

I only get (when I turn on “auto” on the AVR) a Multichannel 7.1. When I play True HD or DTS Master Audio from the PC or from my other devices (before iI got the Vero) the AVR turns to this mode.

I switched the Vero to passtrough and plugged in a 4k compatible HDMI cable.

#6

Hi

Okay. A bit more information is needed so we can work out why that’s happening. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

It will also help if you can take some photos or screenshots of the audio settings so I can see if anything is amiss.

Cheers,

Sam

#7

So I have tested several cabels, serveral HDMI inputs, also Firmware from 04/2017, 05/2017 and the brand new. Always the same issue - No Atmos and DTS:X

#8

Can you post the debug log please? Just enable log debugging; reboot; play a DTS HD clip and post the logs via My OSMC -> Logger.

What’s strange is that you say DTS HD doesn’t work; despite it being enabled in the image you’ve posted. That’s why some logs might help.

Also: the clips you are trying all seem to be ATMOS clips. Try:

DTS HD Out of the Box (Short)

from https://thedigitaltheater.com/index.php/dts-trailers/

Sam

#9

http://paste.osmc.tv/gowogetitu

Here is the log, I activated it, than started the file and stopped.

#10

Thanks. Your amp is advertising support for the following formats:

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 8 ch, 32/44.1/48/88.2/96/176.4/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
DTS, 6 ch, 44.1/48/88.2/96 kHz,  bit
OneBitAudio, 6 ch, 44.1 kHz,  bit
Dobly_Digital+, 8 ch, 44.1/48 kHz, 16 bit
DTS-HD, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16/20 bit
MAT, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16 bit
DTS-HD, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16 bit

I see you tried: SERVER-PC/TV Serien und Konzerte/Sound Demo/Atoms/Dolby_Amaze_Lossless-ATMOS-thedigitaltheater.mkv.

I’d like to see DTS HD working first, as you said that didn’t work and we are not aware of issues with that. Can you try the clip I suggested above?

Also: please enable debugging (Settings -> System), then I can see what is going on when you try and play the clip

Thanks

Sam

#11

Here U are
http://paste.osmc.tv/jihatetuca

#12

Sorry, seems there is some missing, here´s the complete log
http://paste.osmc.tv/pabugizova

#13

Hi – that’s not a debug log still, so I can’t see what exactly is going on.

See http://kodi.wiki/view/Log_file/Advanced#GUI_settings

#14

Mhhh…I tried once more
http://paste.osmc.tv/yivadosase

otherwise I use the xml method.

#15

So now here should be the right one!

#16
CVideoPlayerAudio:: synctype set to 1: resample

I think you have Sync Playback to Display on. This will disable passthrough. This is by design. Enable Adjust Refresh Rate instead.

1 Like
#17

You´re my hero, it works!
Thank you - don´t know anything about it.:slight_smile:

#18

Glad it’s working for you now

Sam

#19

I have received the Verto 4k+. Thank you.
After installation it applied an update and reboot. Ok-
Almost everything works correctly but the Atmos Audio.
Vero is sitting side by side with my X96 Max running Coreelec.
Audio in both devices is set to passtrough. While in Coreelec I see all the audio types after enabling passtrough and check everything, in Osmc after enabling passtrough, there is no audio format to check .
So I thought that it allowed all the supported formats to passthrough.
Then I played a 4k Hdr movie with Dolby Atmos track but the system did not recognize it as Dolby Atmos, altough it was played (maybe in pcm?).
Same movie played trough the X96 Max/Coreelec activated the Dolby Atmos logo and audio.
Same setup same components. As said both the Vero and the X96 are sitting side by side and connected to the same system. To be sure I also used the same Hdmi port for test. No way to get Atmos.
For your information the Vero is running on kodi 18.3 compiled 2019-08-05

#20

Make sure you are scrolling down below the passthrough setting. You can also try setting to expert menus in the lower left corner of that settings menu.