Vero 4K+ and Dolby Atmos

Hi Everyone,
I wondered if someone might be able to advise on this.

Vero 4K+
Onkyo HT-R494
Samsung UE55JU7500T TV

Vero connected to Onkyo HDMI input and Onkyo connected to TV (passthrough)

I have plenty of media files which are Dolby atmos but for some reason I cannot seem to get the Dolby Atmos icon to show on the receiver. I don’t know if I’m actually getting a dolby atmos signal coming from the vero.

I have used a specific HDMI input on the TV from the Onkyo receiver because that’s the specific one I think which allows passthrough, according to Samsung, although I might also be wrong with that.

A little advice on how I’m using this equipment would be highly appreciated, thanks!


Pleas post some logs so we can see what audio settings you’ve set:

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi there, i’ve logged the file to

Let me know if that works!

Reproduction steps:
I set the logger to enabled and rebooted as you suggested. After reboot I played “Rampage” which is Dolby Atmos for around 4 minutes, and then stopped it. I then went into settings, switched back to the standard OSMC skin, re-added the “My OSMC” menu item and then uploaded the log.

FYI, I normally use the Horizon skin, and I’m hoping that has no bearing on anything.



Try turning off Sync Playback to Display, as pass-through doesn’t work properly with this option turned on.

Thanks Tom.

Hi Tom
I’ve done just that and I’m now showing DTS on the receiver, which is definitely a step up!

1 Like

Thanks, @Tom_Doyle!

@mikepjbell, the audio settings look fine. It should work as expected now :slightly_smiling_face:

1 Like

Yes looks like Dolby Atmos is coming through now… superb!!

Thanks for your help chaps, nice to know that I’m getting the best out of this equipment now :blush: