Vero 4k+ and loss of display after a long idle time

I’ve had a Vero 4k+ for just under a year (and thoroughly enjoying it!), and have upgraded through the 4.9 kernel test build and up to the latest Kodi 19.1 release.
However, since the Kodi 19.1 release, I have a problem that if the Vero is left idle for a period of time (I think somewhere between 24 to 48 hours), then when I come back to it the display output is not longer functioning :frowning_face:
The unit is still running, and I can SSH in to it fine, but no amount of unplugging/plugging in the HDMI lead helps, and all I can do is reboot the unit (either via SSH or a physical power cycle). Then it is perfectly fine, until about a day or two later.
During this time, the TV will be switched between on and standby a few times, but not selecting the Vero’s HDMI port (basically using other HDMI devices or the TV itself).
I’ve tried to capture debug logs for the unit, but unfortunately it appears that it needs too long to gather the logs and the logs are too big

osmc@osmc:~$ paste-log /boot/uploadlog.txt
Unable to upload log. Log file is too large. (20MB)

The Vero is plugged in to my Sony BRAVIA KD77AG9 directly (HDMI 4), and the TV is using eARC back to my Denon AVC-X3700H amp (HDMI 2), so I am not using the HDMI switcher in the amp at the moment (I had some issues). Both the Sony and the Denon are on their latest firmware (the TV updated in the last week or so).

What can I do to provide some kind of useful logs?
Or is this a known issue? [I did try looking back in the forums, but couldn’t see an issue detailed like this]


1 Like

Which screensaver are you using?
Also next it happens login with ssh and try sudo systemctl restart mediacenter

1 Like

My screensaver settings are all still default and are just the screen dim

    <setting id="screensaver.mode" default="true">screensaver.xbmc.builtin.dim</setting>
    <setting id="screensaver.time" default="true">3</setting>
    <setting id="screensaver.usemusicvisinstead" default="true">true</setting>
    <setting id="screensaver.usedimonpause" default="true">true</setting>

I believe I tried restarting mediacenter before as one of my own fault-finding attempts (with no success), but I will repeat it to be sure and report back.

Update: I completely forgot to mention that I use Emby Next Gen plugin v5.3.4 :blush: kind of important omission, given that runs periodically in the background.

Try restart Kodi a couple of times (to clear Kodi log) and then grab-logs -A. This should shrink your logs sufficiently.

1 Like

Thanks Sam, will do :slight_smile:
Looking in my “uploadlog.txt” file though, it seems to be “System Journal” that contains the most data, at just over 250,000 lines of log for a 37 hour period of logging.
It is just full of “osmc kernel: hdmitx:” entries (around 189,000 lines containing that text), with chunks of them repeating every 20-40 seconds (by the looks of it).
The “Kodi Log” is just shy of 20,000 lines, so a lot less.

Okay, so it went wrong again just now, having been rebooted late last night (to enable debugging)
I issued a
sudo systemctl restart mediacenter
but this didn’t get the display working :frowning:

So I gathered the logs and checked that the “Kodi Old Log” was the one from when it went wrong (and it was), and then tried to upload the logs …

osmc@osmc:~$ paste-log /boot/uploadlog.txt
Unable to upload log. Log file is too large. (17MB)

but they are still too big :cry:

What else can I tried to get the logs to you?

If it’s all the same “osmc kernel: hdmitx:” lines, it shouldn’t hurt to remove a few thousand of them. Just keep the current ones from the time frame when you turned on your TV. This should shrink your log to a manageable size.

We will have an update soon that should remove a lot of HDMITX log spam.

1 Like

try to first only upload that with paste-log /home/osmc/.kodi/temp/kodi.old.log

1 Like

So here is the kodi.old.log

Even my vero4k, after a few days on standby, is no longer reachable via ssh and does not respond to pings.

I’ve searched the logs, but can’t find anything…

Surely something odd on the HDMI. Did you try a new HDMI cable?

Can try if the HDMI lock temporarily solves your issue.
System->Display->Lock HDMI HPD

I did try the “Lock HDMI HPD” setting, but it didn’t appear to work (with a reboot in-between to make sure the setting was fully active). But I will try it again to be sure.
As to the HDMI cable, it is the same cable I have been using for the last year, but this issue has only started since updating to the 2021.8/Matrix build of OSMC, and didn’t happen on the old builds (2020.11/Leia, or the 4.9 kernel test build). There are no issues with display when actually using it to playback content, with HDR/SDR/DTS/Atmos all working perfectly. It just looses its display when I come back to it after a day or so of idle.
However, I will also swap out the HDMI cable too to verify :+1:

Good News / Bad News :slight_smile:

So I enabled “Lock HDMI HPD”, and ran this test twice to be sure: once during the day yesterday, and then again overnight.

  • Bad News: the display still becomes unresponsive (left overnight), and there is no apparent output from the Vero4k+ unit :frowning: using both genuine Vero remote and Logitech Harmony remote, there is no picture and no sound coming out the amplifier.
  • Good News: a sudo systemctl restart mediacenter does return a functioning Kodi, without the need for a full system reboot :slight_smile: both remotes and sound all working normally

So here is the log, with the Kodi Old Log being the one from when the issue occured

I will now wait a longer time to see if the Vero4k+ becomes unresponsive to a Kodi restart (as the previous times I checked were perhaps not as frequent as while I am actively looking in to the issue).

Lock HDMI HPD: true
GUI Resolution: 3840x2160 @ 60p

Set GUI to 1080p
Disable HPD Lock

1 Like

Thanks Sam, I’ll give it a go at the weekend.
I’m leaving the unit on “soak” until Saturday morning, to see if it doesn’t wake up on a sudo systemctl restart mediacenter and then I’ll try adjusting the display and disabling HPD lock.

Okay, I left it just over 48 hours, and it still did recover with a sudo systemctl restart mediacenter. So this is definitely an “improvement” over having HPD lock disabled, where a full system reboot was required to get things working again.

I’ll now try setting the screen resolution to 1080p and disable the HPD lock.

Well, after 5 days, it hasn’t done it again :slight_smile:
I have been using it every day though, so I’m now leaving it alone for the next day or so to be sure.
I would not have assumed that setting the Kodi resolution to >1080p would cause this kind of issue, but clearly it is and somehow enough “damage” is done to take out the OS too (requiring full reboot). :astonished:
But I am glad it is probably such a simple “fix” :+1:


Bad News, I’m afraid :frowning:
I left it alone until just now, so a good 48 hours, and the display was blank and Kodi wouldn’t “wake up” to remote control presses.
I issued a sudo systemctl restart mediacenter, but the display stayed blank (I could see that the Kodi.bin process had restarted in SSH).
I rebooted my Vero4k+, and that sorted the problem.

So it looks like whether the Kodi GUI is set to 4k or 1080p, the issue happens for me (after some amount of time).
The only thing that makes a difference so far is the “HPD lock”, which allows me to restart just Kodi rather than having to perform a complete system reboot.

Is there anything else I can try, based on the logs I have managed to gather? I wasn’t logging just now, but I suspect they would have been too large again.