Vero 4k+ and osmc DVB-T2/DVB-C TV dongle

#1

vero 4k+ and osmc DVB-T2/DVB-C TV dongle

Hello everybody,
back in february i bought, along with a Vero 4K+, the osmc.tv dvb-t2 tv dongle but I managed to install it only recently.
Now I am trying to figure out how to configure it properly. I have experience on linux but I never had a tv adapter before so I read a few posts on this (and other) forums and then I began to configure.

Here is what I did:

  • install the usb dongle and connected the tv cable.

  • install TVHeadend Server via the My OSMC Addon -> App Store

  • install the Tvheadend HTSP Client with these connection Settings (I left the default settings in the other sections):

    • Tvheadend hostname or ip address: 127.0.0.1
    • HTTP Port: 9981
    • HTSP Port: 9982
    • Username: osmc
    • Password: osmc

I verified that the Tvheadend was running and bound to the proper ip:

root@osmc:~# ps -fe| grep -i tvheadend
osmc      1132     1  0 21:37 ?        00:00:03 /usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video
root@osmc:~# lsof -itcp:9981
COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
tvheadend 1132 osmc    6u  IPv4  12534      0t0  TCP *:9981 (LISTEN)

then I connected to http://osmcservername:9981, logged on as osmc/osmc and I went through the wizard.
I let it search for channels overnight but it didn’t find any.

As you can see in the attached screenshot, I can see only one dvb adapter (realtek) using the web interface.

On the other hand I have a different result if I use w_scan from the command line with tvheadend daemon stopped (I can see also the Sony one):

root@osmc:~# systemctl stop tvheadend.service
root@osmc:~# w_scan -c IT
w_scan -c IT
w_scan version 20161022 (compiled for DVB API 5.10)
using settings for ITALY
DVB aerial
DVB-T Europe
scan type TERRESTRIAL, channellist 4
output format vdr-2.0
WARNING: could not guess your codepage. Falling back to 'UTF-8'
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
	/dev/dvb/adapter0/frontend0 -> TERRESTRIAL "Realtek RTL2832 (DVB-T)": good :-)
	/dev/dvb/adapter0/frontend1 -> TERRESTRIAL "Sony CXD2837ER DVB-T/T2/C demodulator": very good :-))

Using TERRESTRIAL frontend (adapter /dev/dvb/adapter0/frontend1)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.10
frontend 'Sony CXD2837ER DVB-T/T2/C demodulator' supports
DVB-T2
INVERSION_AUTO
QAM_AUTO
TRANSMISSION_MODE_AUTO
GUARD_INTERVAL_AUTO
HIERARCHY_AUTO
FEC_AUTO
BANDWIDTH_AUTO not supported, trying 6/7/8 MHz.
FREQ (42.00MHz ... 1002.00MHz)
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
Scanning DVB-T...
Scanning 8MHz frequencies...

What I am missing?
Can you give me some pointers?

Thanks a lot,
Michele

P.S. please forgive my bad english.

#2

Try this:

sudo systemctl stop tvheadend
rm ~/.hts/tvheadend/input/linuxdvb/adapters/*
sudo systemctl start tvheadend

Now log in to the TVH webui, find the tvadapters page again, enable only the sony tuner, attach to it the network which has your local muxes, and hit Save.

After a while, you should get some channels showing up.

Full story here: Watching live TV with a USB DVB tuner or network TV tuner

1 Like
#3

As @grahamh has suggested, you may need to purge the tuner cache. TVHeadend is quite lazy at updating tuner information.

Cheers

Sam