Vero 4K+ and recording in TVHeadEnd

I recently got a Vero 4k+, which by the way I’m really liking. I installed TVHeadEnd from the Vero app store and all went well and it all works fine for both viewing and recording live tv (using an HDHomeRun Quattro).
My intention is to save the recordings onto an external SSD, plugged into the spare USB port on the Vero.
I plugged in my NTFS formatted 480GB SSD, got a message to say ‘mounted’ (or something similar), but I have absolutely no idea how to install the drive or change the recording location to this drive.
I’ve searched the forum extensively to try to find a topic that matches my case, but can’t find anything.
I should point out that I’m really new to linux (command line stuff) and any topics I find (no disrespect), go off into really technical explanations as how to ‘mount’ and ’ give permissions’ etc.etc.
Could anyone provide me with very basic instructions (and it’ll need to be basic, step - by-step stuff), on how to achieve my goal?
Many thanks, in anticipation.

You should prob be able to set the location in the tvheadend settings. The drive should show up in /media/<drive label>

It’s also probably wise to use a powered USB hub for the drive as the Vero USB ports may not be able provide sufficient power if the drive does not have it’s own power supply.

Thanks for the prompt reply.
So I take it that, if I use a powered usb hub, there is nothing else I need to do to configure/initialise the drive for use on the Vero?
The path set in the TVHeadEnd webpage for recordings is: ‘osmc/home’ - so I’d need to change this path to /media/ - (name I gave to the drive)
If I wanted to create a folder e.g. TVRecordings - how would I do this?
Thanks, again

You could do that via either file manager (under settings) or you could do that via SSH (command line).

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Correct. But… if you are only going to use the drive on the Vero, it would be a good idea to reformat it as EXT4 instead of NTFS as it will perform better. Especially for writes. If you are interested in doing that we can help you. If you still want to use the drive on Windows, then it would be better to reformat it as exFAT as that also performs better than NTFS (but not as good as EXT4).

Many thanks - as I aim to use the drive only on the Vero, I’d be quite happy to format it as EXT4.
All I really want is to create a folder on the drive that can be used to record TV programmes, which hopefully I can then access via my network and copy these files across to my MacBook (for editing and archiving the to my NAS drive).
I just get lost in the command line stuff unfortunately, at the moment - but do want to learn!

Thanks guys - this was much easier to achieve than I expected. As was stated, once the USB disc was plugged in, OSMC mounted the disc (which I’d labelled ‘DVR’ and once I used SSH and ran df -h command, the disc showed up as /dev/sda1 mounted in /media/DVR.
From there I pointed TVHeadend to /media/DVR path and it all now works.
But, I still cannot work out how to create a new folder in the DVR usb drive?
I tried mkdir command but got a message saying ‘only root can do this’ (or similar), so tried sudo command, but then got the message saying ‘busy or unable to create directory’ (not sure of exact wording).
If anyone has any ideas how I can do this, I’d be really grateful!
Many thanks again.

What are the exact commands that you ran?


I used
mount /dev/sda1 /mnt
and got
‘only root can do that’
So I then tried:
sudo mount /dev/sda1 /mnt
and got:
‘Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the ‘fuser’ command’.
not sure if this helps?

The reason is that you still use the NTFS file system on that drive. We suggest to use EXT4 since NTFS creates a lot of overhead which means you’re limited in performance.

  1. if you still want to use NTFS, you’ve to install another package:
    sudo apt install ntfs-3g
    otherwise go to step 2.

  2. if you want to use EXT4 file system, the disk does not contain any data and can be purged:

  • locate the device name using the dfcommand, let’s assume in this example it was /dev/sda1
  • unmount the drive: sudo umount /dev/sda1
  • kill the drive contents by overwriting the first 64 MB: sudo dd if=/dev/zero of=/dev/sda1 bs=1M count=64
  • create a new partition: sudo fdisk /dev/sda(leave out the last digit of the device name found with df)
  • within fdisk delete all partitions of the hdd with command (d), create a new one (n) and accept all default values and write the info down to disk (w)
  • create the new file system: mkfs.ext4 /dev/sda1 -T largefile -m 1 -L MyDISK
    (-T largefile means the disk only contains large files and by that don’t need a huge amount of inodes, -m 1 only reserves 1% of the disk space for maintenance/recovery purpose, -L MyDISK assignes the volume label/name myDISKto the hdd)
  • let OSMC scan for new partitions: sudo partprobe (ignore any errors) or simply sudo reboot
  • that’s it, your new formatted hdd should be found somewhere at /media by that

Thanks so much JimKnopf!! - I followed your instructions to the letter and have reformatted my USB drive to EXT4. I’m now starting to understand the syntax of the command line a little more. It’s very interesting, but so challenging for a new starter!
The only issue I found after carrying out all the steps, was the ‘sudo part probe’ command that yielded a ‘command not know’ (or similar message).
All I then did, was to unplug the USB drive and replug it after a few moments. The df -h command then showed it as /dev/sda1, mounted at: media/DVR (My substitute for the ‘MyDISK’ label in your example).
I left the recording location in TVHeadend path alone as /media/DVR and it works great.
Many thanks for taking the time to hand hold me through this process - very much obliged!!


Thanks - but i did use partprobe as one word (it’s just my MacBook that spilt the word during typing - lol!)
The sudo partprobe still yields ‘command not known’??

‘Command not found’ - I mean

Either sudo apt-get install parted or reboot and you won’t need to run partprobe.

1 Like