Vero 4k and some 4k movies issues

I got issues playing some 4k movies.
See log:

I get this warning in kodi

Please help.

Please provide mediainfo of the file. Where is the movie located? Disk, NAS? Wired, wireless? This indicates the source cannot provide the file fast enough.

The file is located on an unraid server
All connected wired.
It plays fine with zidoo x9s mediaplayer on same network
So its not the network , nor the file nor the server.
I can provide mediainfo… But its with other 4k movies too, all those play fine with zidoo x9s… Windows kodi machine… But not vero 4k

Might this be the limitations of the network connection on the vero 4k which is not gigabit?

Indeed. Please check the bitrate of this file. If you have 5Ghz wifi you can try that. I get about 130mbps wireless vs 80mbps wired. For 4K HDR 80mbps can be a problem.

52,1 Mb/s

if you cant read the text in the first pi what kodi says
it say

Source too slow
Readingspeed too slow to playback continuously

Strange, just tried it again with other players, no problem

Total average bitrate = 58,3 so that means peak is higher. You might want to use a tool like Bitrate Viewer (Bitrate Viewer 2.3 Free Download - VideoHelp) or to exclude network issues copy it to a USB-stick.

Unfortunately, the file is H.265, which is not supported by Bitrate Viewer. I can’t find a similar tool for H.265…all I get when searching is recommendations to use FFMPEG to output info that can be imported into a spreadsheet and graphed.

Fastest way to check: copy to an USB-stick and see if you get the same problems. If not it’s the network.

You could try this on the Vero: GitHub - zeroepoch/plotbitrate: FFProbe Bitrate Graph

iftop lets you see bandwidth throughout on an interface

No problems on usb , nor over the network with other player… Guess its the player then?
What to do?

In order of my preference:

  • Switch to 5Ghz Wifi (I get 130Mbps with that)
  • Re-encode with lower bitrate
  • Buy a Vero4K+ which has gigabit ethernet

Mmm not one of the three options sound good for me.
1 ok for testing but not to use all the way, not stable enough
2 reencoding , hell no, it should just play, like with any other player
3 buying the same product over again just for gigabit ehternet?

If an adapter fixes the problem i would buy one, but im not sure it will

There have been other posts about problems with high bitrate encodes. I don’t know of any other fixes and I’m out of pixie dust…

I’ve read somewhere people using a Gigabit adapter. Just search the forum and you should find something.

I remember you had some problems before and a reinstall resolved this. Has this only occurred recently? It’s possible some changes (such as third party addons or builds) have introduced this problem.

Can you post some some logs so we can look in to your issue?


A sub £10 USB gigabit adaptor will give 330 Mbps

yeah i knew someone would make the link :slight_smile:
this occures with some latest releases
other 4k movies which i tested with the earlier issue, still play flawless
so its with some 4k movies

no extra addons installed since then

i already posted the log

doubting to get the adapter
or if i could test the vero 4k+ i could see if thats the issue :wink: hint hint lol

Maybe of help, at least a workaround if it applies. I had a few problem mkvs (the last Pirates of the carribean film was one) and they were all TrueHd audio. Unticking TrueHd compatable receiver option in Kodi solved it. Now, on the latest update with fstab connections to a win 10 server and with an Anker Gigabit adapter to my Vero 4k not had an issue since (and TrueHd re-enabled).
As I said, might not be related to your issue but easy to test.