Vero 4K and soundbar

Hi,

I have a Vero 4K connected through a soundbar to the tv ARC. The tv is a sony xe930 and the soundbar is samsung ms750. I would like to know, what the audio and video settings should be to get the best out of it. When I play a 4k video through the vero the tv doesn’t switch to 2160p, but stays at 1080p, but when I have the hdmi cable connected direct to the tv, it does switch to 4k.

Hi,

to get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding.
There will be hopefully the OSMC April 2018 update this or next days; perhaps, it’s worth a try with the new OSMC release before deep troubleshooting.

I have just read a post about hpd lock. I have set it to on and now it’s switching to 4K. It’s no major issue that I have to produce a log. I just want to know what settings people are using.

Hi @baseman,

checked the manual of the Samsung soundbar and it looks like the supported sound formats are limited to

  • linear PCM 2 channels
  • Dolby Digital
  • DTS

With that, please, check your Vero’s audio settings and set them to the following:

Audio device: HDMI
Number of channels: 2.0
Output configuration: Best match
Passthrough: enabled
AC3 passthrough: enabled
AC3 transcoding: enabled
DTS passthrough: enabled
DTS-HD/TrueHD/E-AC3 passthrough: disabled

It might be that E-AC3 (Dolby Digitial Plus or DD+) can be processed by the sound bar, so it’s worth a try to verify this with the DD+ sample at Samples - Official Kodi Wiki with activated E-AC3 passthrough setting.

Keep in mind to disable “sync playback to display” under settings->player->videos for passthrough to work; active “sync playback to display” prevents passthrough usage!

You should set your TV’s refresh rate to be adjusted according to the source’s frame rate for best results. For this set "Adjust display refresh rate” to Always or to On start/stop under settings->player->videos; "Adjust display refresh rate” set to Always prevents the screensaver to work!