Vero 4K and Zeroconf/Yatse support

I bought a Vero 4K and it seems to work pretty good. I have a problem with accessing it from Yatse (which worked great on my RP2). I tried to write the IP adress as well but Yatse could not find the Vero. Does anyone know what I should do to be able to control my Vero 4K from Yatse (or similar app)?

I don’t use Yatse but I am sure someone does and can help. Make sure the web server and settings to allow the device to be controlled remotely are enabled

Why does not Vero 4K has zeroconf?

OSMC has avahi

How do I enable that on the Vero 4K?

It should be installed and running. It is working just fine on my 4K.

From another machine on my network (which also has avahi):

user@mgwt:~$ ping osmc.local
PING osmc.local ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=64 time=1.57 ms
64 bytes from ( icmp_seq=2 ttl=64 time=1.13 ms
64 bytes from ( icmp_seq=3 ttl=64 time=0.888 ms
--- osmc.local ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 0.888/1.201/1.576/0.284 ms

As you can see, I called my OSMC box osmc! I thought dillthedogsosmc was probably a bit too long.

Are you using WiFI on one device and Wired on another? Some routers don’t allow Avahi (DNS broadcasting) packets to cross from WiFi to Wired for security reasons

I have seen a lot of scenarios where Avahi does not behave as expected. As such, I recommend a static IP on Vero 4K and configuring Yatse this way. This should work, but you say when you enter the IP address it doesn’t. What do you see (screenshots would be great), and have you verified the settings recommended above?



Did you follow the Yatse instructions on how Kodi should be configured for use with Yatse?

For Zeroconf to work, the devices need to be on the same subnet and the Router/AP must allow it to pass.
I disabled it on all my devices as I hate the chatty-live these devices develop over time :slight_smile:

But - as I’m on the same subnet, Yatse still works.
Zero-conf is only used for detecting the host. if you know the IP of your device, you can configure it manually too.,

I can ping to it both using its name (vero4k.local) and its IP address. But Yatse can’t connect to it even if I enter the IP adress. Very weird…

On dozens of installs, when these instructions have been followed, I’ve never experienced a connection issue.

Can you screenshot the error or message you get in Yatse?

The instructions look different then what you can see on the Vero 4K. There is no setting for enabling Zerozonf on the Vero 4k for example.

Did you enable Expert Settings in the lower left menu?


Also, I can ping from my phone to my vero using the IP-adress but not its name (vero4k.local)…

I tried Kodi remote on my Ipad but that could not find the vero4k either…

It just says it can’t find any host.

Zeroconf is not necessary to manually input your Kodi details into Yatse.

A search of the Kodi forums reveals serious issues with Zeroconf on Kodi 17 and their decision that it may not be included.


Some possibly conflicting information, it seems:

First quote: can ping by name and IP address (but from what is not specified, though it implies from the phone).
Second quote: cannot ping by name but can ping by IP address from the phone.
Third thing about the ipad not finding the host? Perhaps bonjour isn’t installed. (I don’t have an ipad to check if it’s there by default).

Anyway, the nub of the problem seems to be that Yatse can’t connect even using the IP address.