Vero 4k Asus gigabit ethernet adapter

This is unfortunately the only real issue. I get emails daily asking what Fast Ethernet is, and we lose a lot of sales from potential customers insisting that Gigabit Ethernet is absolutely necessary, even to watch 1080p content.

It still makes sense for us to stay at 100Mbps for the next couple of years; and 1000Mbps can cause problems with Flow Control.

Sam

I do agree on that. While testing the Vero 1 myself,. I noticed that we had many flow-control issues there.
The Vero 2 and Vero4k handle it way better.

The main reason why I desire a gigabit adaptor is that I am hoping for improved performance while jumping chapters. I am very pleased with the Vero 4k but jumping chapters or generally jumping forward feels a bit sluggish. This is the only criteria where my old shield tv absolutely annihilates the Vero 4k (otherwise the shield tv is garbage compared to the Vero 4k). I think I will spend 10 bucks on amazon for a gigabit adaptor and give it a try. Not really a huge investment and since it is amazon, I even can return it without problems.

Hi, could you provide a link to this adapter?
Thanks.

I have not decided or bought one yet…

I ordered this adapter from Amazon (Germany) because it has the desired chipset (RLT8153) and also comes highly recommended:

I will test it as soon as it arrives. Main focus will be the behavior on jumping chapters and jumping forward on high bitrate files.

2 Likes

Looking forward to the results.

Well, the Veo4K has USB 2.0 ports. Hence the adapter will only be able to get around 480Mbps in the best case scenario.
Let us know how it goes. Use iperf to test it :slight_smile:

Ok here are my first few thoughts after a quick test with the adapter posted above.

  1. Installation is no problem at all, just plug it in, plug the lan cable in = ready to go

  2. Tested playback and skipping forward on a 63gb 4k Movie (90mbit/s)… a huge difference compared to the internal ethernet port!! It skips almost immediately, tested 10 second jumps, 10 minutes jumps and chapter jumps… the waiting wheel is almost not visible anymore. With the internal adapter, I had the wheel go from 0% to 1% to 2% to 9% to continue playing, which was roughly 1.5 seconds… now I only see a very brief flash of the wheel and playback continues… It finally feels like it felt with the shield tv with its gigabit port.

  3. Had trouble getting iperf to work but since the adapter has the exact same chipset as the mentioned asus adapter in the first post, it probably has the same speed, which is maxing out the usb 2.0 speed

  4. no fstab being used, just normal samba shares with my NAS (Synology DS216+II)

So summary, the adapter improved my Vero 4k experience just the way I had hoped. I will continue to use it and monitor the performance. Long term stability of course is a huge issue, this quick test obviously does not cover that. But the first impressions are great. I put great value at the responsiveness of my devices, everything has to feel immediate and snappy.

edit: the network settings I use are buffer = 1073741824 with readfactor = 5

Sam, why don´t you just add a proven usb adapter to the osmc store? That would surely appeal to many potential customers. Especially if you sell it for a modest price. Nobody is forced to buy it, but those who feel that 100mbit/s is too narrow get a cheap option to triple the speed. And from what I remembered, the shield tv and its gigabit lan maxed out around 300 mbit/s as well…

1 Like

selling an usb2ethernet adapter in the osmc shop is surely a great idea. In the meantime I used an Anker adapter and measured the connection from a Synology NAS to the Vero4k with iperf3

Connecting to host 192.168.1.22, port 5201
Reverse mode, remote host 192.168.1.22 is sending
[ 4] local 192.168.1.166 port 51526 connected to 192.168.1.22 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 38.6 MBytes 324 Mbits/sec
[ 4] 1.00-2.00 sec 38.7 MBytes 324 Mbits/sec
[ 4] 2.00-3.00 sec 38.7 MBytes 324 Mbits/sec
[ 4] 3.00-4.00 sec 38.6 MBytes 324 Mbits/sec
[ 4] 4.00-5.00 sec 38.6 MBytes 324 Mbits/sec
[ 4] 5.00-6.00 sec 38.6 MBytes 324 Mbits/sec
[ 4] 6.00-7.00 sec 38.6 MBytes 324 Mbits/sec
[ 4] 7.00-8.00 sec 38.6 MBytes 324 Mbits/sec
[ 4] 8.00-9.00 sec 38.5 MBytes 323 Mbits/sec
[ 4] 9.00-10.00 sec 38.5 MBytes 323 Mbits/sec
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 391 MBytes 328 Mbits/sec 10 sender
[ 4] 0.00-10.00 sec 386 MBytes 324 Mbits/sec receiver
iperf Done.

Looks quite good. Beside some problems (a few dropped frames and one case of buffering) with our old troubled friend John Wick every 4k HDR file played without any troubles so far. But looking at the network speed, the cause for the problems can hardly be the network speed.

So, if you are afraid, that Fast Ethernet is not fast enough for you, buy an adapter for 11 or 12 Euros. No installation required. I just plugged it in and it worked.

If you want to know what the upload from the Vero4k to the NAS looks like (slower but not important IMHO):

Connecting to host 192.168.1.22, port 5201
[ 4] local 192.168.1.166 port 51598 connected to 192.168.1.22 port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 22.8 MBytes 191 Mbits/sec 0 313 KBytes
[ 4] 1.00-2.00 sec 22.4 MBytes 188 Mbits/sec 0 344 KBytes
[ 4] 2.00-3.00 sec 21.8 MBytes 183 Mbits/sec 0 344 KBytes
[ 4] 3.00-4.00 sec 22.2 MBytes 186 Mbits/sec 0 345 KBytes
[ 4] 4.00-5.00 sec 22.5 MBytes 188 Mbits/sec 0 426 KBytes
[ 4] 5.00-6.00 sec 22.0 MBytes 185 Mbits/sec 0 436 KBytes
[ 4] 6.00-7.00 sec 22.4 MBytes 188 Mbits/sec 0 436 KBytes
[ 4] 7.00-8.00 sec 22.2 MBytes 186 Mbits/sec 0 436 KBytes
[ 4] 8.00-9.00 sec 21.7 MBytes 183 Mbits/sec 0 436 KBytes
[ 4] 9.00-10.00 sec 22.0 MBytes 185 Mbits/sec 0 436 KBytes
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 222 MBytes 186 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 221 MBytes 185 Mbits/sec receiver
iperf Done.

The Anker one is also with the RLT8153. Probably using the driver for the RLT8152 that is natively supported by OSMC.

People interested should check daily Amazon (Lightning) Deals, those adapters are often available there.

+1 for having an official adapter. Not that i need one now :wink:

The smartest way would be offering a combined usb hub / gigabit adapter. Costs only a buck or two extra. That would also counter argument, that all usb ports would be used (considering the bluetooth dongle also uses one usb port).

1 Like

This I’d support very much! If one doesn’t use a GBit LAN adapter or a DVB-T dongle, the need for a USB hub is not a very likely one. But if a USB hub (that might even use both USB ports of the Vero 4k to maximize bandwidth or throughput) already includes a LAN adapter, it would be great! :+1:t2::slightly_smiling_face:
I’d definitley get one of those adapters, if they were offered in the OSMC store.

1 Like

Update: After the december upadte i’m able to play the 180 mbit files.

1 Like

Me too, but I discovered at several movies with high bitrates that at peaks ( one scene /movie) you‘ll get an freeze for buffering. hope this still will be improved. I mounted everything via nfs fstab…

@Joker1982 The kernel also understands nfs4, so depending on your NAS this is worth a try although the performance improvement isn’t that high.

Addition: Read some stuff and it looks like the highest possible nfs protocol will be negotiated between the client and server if you only specify ‘nfs’ in fstab, so no need to invest time for my post … but to check whether the highest nfs protocol is enabled on the NAS is a good idea anyway.

thanks…

I‘m using OpenMediaVault, so I‘m quite sure its already enabled. Also the brandwith in network is OK. I think it‘s a performance issue from the Vero 4K. Always when you play the full movie and have files with bitrates above 60mbit I‘ll face this issue in one to two scenes per movie( high peak scenes). cache is going down to zero and it takes until it fills up again. bit it‘s quite strange as the balance of movie have 40-100 percent cache…

What hardware are you using?
I am using OMV 3.x through NFS (Not ising the FSTAB), and my NAS is a HP Microserver gen8 with a Xeon E3-1220L V2 + 16GB Ram + Software-Raid 5 in 3+1 setup (3x4TB + 1 Spare) on ext4FS filesystem - connected through 2x1Gbps network interfaces to a switch (Bonding on NAS side only), and that switch has a dedicated link to my Vero4k.
That Disk setup is capable of providing 250MBytes/s sustained over a long period of time while the NAS is under load, and peaks of up to 400MBytes/s of data. So very fast. The network is not fast enough to forward all that data :slight_smile:

I had switched to that setup as I realized my old NAS (SS839 from QNap using a 1.6Ghz Atom CPU + 2GB of Ram) was not able to provide decent speed for high quality medias.

It is enough that your NAS is stuck for a second to stop a high-bitrate stream and that causes some stuttering.