Vero 4k Asus gigabit ethernet adapter

This I’d support very much! If one doesn’t use a GBit LAN adapter or a DVB-T dongle, the need for a USB hub is not a very likely one. But if a USB hub (that might even use both USB ports of the Vero 4k to maximize bandwidth or throughput) already includes a LAN adapter, it would be great! :+1:t2::slightly_smiling_face:
I’d definitley get one of those adapters, if they were offered in the OSMC store.

1 Like

Update: After the december upadte i’m able to play the 180 mbit files.

1 Like

Me too, but I discovered at several movies with high bitrates that at peaks ( one scene /movie) you‘ll get an freeze for buffering. hope this still will be improved. I mounted everything via nfs fstab…

@Joker1982 The kernel also understands nfs4, so depending on your NAS this is worth a try although the performance improvement isn’t that high.

Addition: Read some stuff and it looks like the highest possible nfs protocol will be negotiated between the client and server if you only specify ‘nfs’ in fstab, so no need to invest time for my post … but to check whether the highest nfs protocol is enabled on the NAS is a good idea anyway.


I‘m using OpenMediaVault, so I‘m quite sure its already enabled. Also the brandwith in network is OK. I think it‘s a performance issue from the Vero 4K. Always when you play the full movie and have files with bitrates above 60mbit I‘ll face this issue in one to two scenes per movie( high peak scenes). cache is going down to zero and it takes until it fills up again. bit it‘s quite strange as the balance of movie have 40-100 percent cache…

What hardware are you using?
I am using OMV 3.x through NFS (Not ising the FSTAB), and my NAS is a HP Microserver gen8 with a Xeon E3-1220L V2 + 16GB Ram + Software-Raid 5 in 3+1 setup (3x4TB + 1 Spare) on ext4FS filesystem - connected through 2x1Gbps network interfaces to a switch (Bonding on NAS side only), and that switch has a dedicated link to my Vero4k.
That Disk setup is capable of providing 250MBytes/s sustained over a long period of time while the NAS is under load, and peaks of up to 400MBytes/s of data. So very fast. The network is not fast enough to forward all that data :slight_smile:

I had switched to that setup as I realized my old NAS (SS839 from QNap using a 1.6Ghz Atom CPU + 2GB of Ram) was not able to provide decent speed for high quality medias.

It is enough that your NAS is stuck for a second to stop a high-bitrate stream and that causes some stuttering.

Well, at least you can play with cache readfactor in the file /usr/share/kodi/system/advancedsettings.xml which is 5 at the moment. Perhaps you can get some improvement by this since you’re now using a gigabit adapter with more bandwidth than the built-in interface of the Vero 4k for which the current value is designed and tested.

Addition: Please, don’t change the original file /usr/share/kodi/system/advancedsettings.xml but use /home/osmc/.kodi/userdata/advancedsettings.xml to make changes persistent against updates.

I already was playing with that settings. But still testing. Yesterday Inolayed a movie with 49,50 Mbit without any issues…

1 Like

Please, share your experience afterwards. If you get it more stable with a better value for the gigabit ethernet USB adapters, this is a valuable information for others. Very appreciate your efforts. :+1:

Did further testing and had again issues. But finally I found a solution which helped until now:

I added the following lines at fstab conf.:

This helped and buffer is not running empty anymore for the moment. But as times before, need ti check with several movies, with high peak scenes…

I wouldn’t do udp, there is always a change of data corruption with udp.
If you can, use vers=4, which defaults to tcp.

1 Like

that option sets the nfs version, so may not work depending on the NAS.

I changed to vers=4, tcp…

Lets see if it will help. With previous conf from my last post, I had again a buffering issue but at a movie with 87,30Mbit…

What speed do you reach when you run a test with dd?
dd if=/path/to/movie.mkv of=/dev/null

When I did a few tests rsize=16384 was faster for me then 8, 32 or 64k

Thanks, will test this as well…

That‘s quite strange now…

With Version 4 I get a result which is more worth. Best result was with version 3, 32768 and udp… But also here I had issues at the end of the movie and it had ine time to buffer :frowning:

Anyone an idea what can be done? It‘s really a pitty that ethernet thing atbthe Vero. Also I‘m wondering why Sammis always writing that it will work, because at big files it won‘t work for the full movie at anyone. Yes, with some tweaking I can get better result but I didn‘t managed one config which will play a full movie with high brandwith (files with over 64 mbit/s) without one hanger…

Today I tested nfs version 3 (udp+tcp) and version 4 (tcp) with the fstab method, a giga ethernet adapater (Anker USB 3.0 auf RJ45 10/100/1000 Gigabit Ethernet Adapter) in combination with my Synology NAS (DS214se) where nfs4 is enabled and the Vero 4k.

The best results I get with nfs 3 or 4 using tcp (with nfs 4 udp is not working/mounting at all). With both nfs versions I get comparable throughput performance of around 35 MB/sec which is absolut sufficient for my purpose.
I used dd if=... of=dev/null status=progress (it uses default block size of 512 bytes) and bonnie++ for the measurements.
If you check with findmnt -u the active mount parameters, you see that nfs 3/4 tcp use 128 KB for rsize and wsize.
Performance depends on many factors and it is not that easy to isolate possible bottlenecks.

Just tried a Rankie USB-Gigabit adapter from Amazon, and like Nickelig, the improvement is very noticeable.

Like him, skipping and fastforwarding is now impressive, no more “clock circle” when trying to skip to next chapter on a 4K movie.

Now the smoothness is perfect. 4K movies start to play instantly, no waiting and no “buffering” when using FF or skipping.

This one uses ASIX AX88179 controller instead of Realtek, but has native support on linux from 3.9 Kernel, so no need of compiling drivers, just plug&play with OSMC.

osmc@Vero4K:~$ iperf3 -c -R
Connecting to host, port 5201
Reverse mode, remote host is sending
[ 4] local port 36974 connected to port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 36.4 MBytes 305 Mbits/sec
[ 4] 1.00-2.00 sec 37.1 MBytes 311 Mbits/sec
[ 4] 2.00-3.00 sec 37.2 MBytes 312 Mbits/sec
[ 4] 3.00-4.00 sec 37.0 MBytes 310 Mbits/sec
[ 4] 4.00-5.00 sec 36.8 MBytes 309 Mbits/sec
[ 4] 5.00-6.00 sec 36.6 MBytes 307 Mbits/sec
[ 4] 6.00-7.00 sec 37.3 MBytes 313 Mbits/sec
[ 4] 7.00-8.00 sec 36.6 MBytes 307 Mbits/sec
[ 4] 8.00-9.00 sec 36.4 MBytes 305 Mbits/sec
[ 4] 9.00-10.00 sec 37.0 MBytes 310 Mbits/sec

[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 369 MBytes 309 Mbits/sec 7986 sender
[ 4] 0.00-10.00 sec 368 MBytes 309 Mbits/sec receiver

iperf Done.

Slightly lower performance than previous users here but works like a charm.

24 posts were split to a new topic: CLS Realtek Gigabit Ethernet Adapter not Working with Vero 4k

I’m in the UK and just got this from Amazon

and I get this level of performance with my Vero 4K! It worked straight out of the box :slight_smile:

Accepted connection from, port 49359
[ 5] local port 5201 connected to port 49360
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-1.00 sec 31.4 MBytes 263 Mbits/sec
[ 5] 1.00-2.00 sec 38.8 MBytes 324 Mbits/sec
[ 5] 2.00-3.00 sec 38.5 MBytes 325 Mbits/sec
[ 5] 3.00-4.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 4.00-5.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 5.00-6.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 6.00-7.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 7.00-8.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 8.00-9.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 9.00-10.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 10.00-11.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 11.00-12.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 12.00-13.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 13.00-14.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 14.00-15.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 15.00-16.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 16.00-17.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 17.00-18.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 18.00-19.00 sec 38.6 MBytes 324 Mbits/sec
[ 5] 19.00-20.00 sec 38.7 MBytes 324 Mbits/sec
[ 5] 20.00-20.20 sec 7.61 MBytes 324 Mbits/sec

[ ID] Interval Transfer Bandwidth
[ 5] 0.00-20.20 sec 0.00 Bytes 0.00 bits/sec sender
[ 5] 0.00-20.20 sec 773 MBytes 321 Mbits/sec receiver

1 Like