Vero 4k+ bandwidth limited after kodi v19 upgrade

Hi all,

I took the plunge and updated my vero to v19 but since then I am having issues playing high-bandwidth videos (such as remuxes 70GB for 2hr), that then pause and stutter.

Pausing the video I can see it is still buffering from the bandwidth monitor and then it plays for like 10 seconds. It simply cannot get enough data it seems.

My setup:

  • GBit LAN all around
  • Windows i7 “server” with HaneWin NFS (not changed for years)

What I tried:

  • Play from USB: no problem
  • Bandwidth monitoring while playing video: seems to be capped at 50 Mbit/s. After pause continues to buffer for like 30sec or so
  • Bandwidth test with iPerf3 vero<->server: 600-700 Mbit/s both ways

Any ideas on what to try next?


Edit 1: Note that I have played this exact same file on the previous version of OSMC without problems, only thing changed is the update to Kodi 19

Edit 2: OT: For the rest 19 is great, it now finally plays my custom remixed 3D frame packed movies with Dolby Atmos without stutter. Also HDR->SDR seems to look better.

That doesn’t look healthy, why isn’t it a stable 920M?

How does it look if you just dd the file from the server to /dev/null?

I was also a bit surprised by that, but maybe it is due to:

  • The signal passed through 4 netgear switches on the way
  • I run the iPerf3 on the windows machine not linux, not sure if that slows things down.

This is the ouput:

Not sure how to do this, any place you could point me on how to set this up?
I had a quick google but don’t see anything under /mnt/? :confused:

That two factors should not influence it.
Looks more like either a flow control issue or cable issue. Does ifconfig show any errors?

Ah are you using Kodi internal nfs access to the server or fstab/autofs based?

First of all, thanks for helping me out, much appreciated!
This is what ifconfig shows:

I just use the Kodi internal nfs access

Ok, while I would be surpized if there was reduction in performance of the Kodi NFS implementation but maybe together with the unstable network it gives the issue.
May I suggest you try autofs to see if it solves the issue. If that is the case we may can revisit Kodi NFS again.

1 Like

Thanks, I will set it up and report back :slight_smile:

Just as an FYI, I used Kodi’s NFS on a Vero 4K+ on Kodi 18 (which was fine), but when I moved to Kodi 19 during testing, that was unusable for me with 4K movies even with 900mb+ throughput according to iperf3. I ended up changing everything over to using NFS via mounts and all my issues went away. I never took the time to look through the Kodi change logs to see what might have happened, but it is possible that the native NFS in Kodi 19 needs better/more stable/more bandwidth to achieve the same result.

1 Like

Ok, managed to set up the network share with autofs and now it is playing flawlessly.

See screenshot, first peak is the buffering, the flat low bitrate piece is a black screen with the static movie title, and the next big peak is skipping 10min ahead. During playback you see this movie has a 100Mbit/s rate, and while skipping forward/backward as much as it can handle.

So to me it is clear the new kodi 19 internal nfs access is limited at approx 50Mbit/s, which is not going to cut it for these high-quality streams. And I am not the only one bumping into this it seems.

So while I got it up and running now (just need to rescan my library), I am sure more people will bump into this replacing half their network before realising it is just a limit of the kodi 19 nfs implementation, so definitely worth a fix or a warning somewhere.

Thanks all that helped out!

1 Like

You can use path substitution instead of redoing your whole library.

It’s good that you’ve back up and running, but you haven’t found out why your network is performing so badly. Receive speeds of 500 Mbps and send speeds of 650 Mbps are too low. (Iperf3 measures the low-levell network speed, irrespective of what data transport layer you’re using on top.) As @fzinken said, the network speed should be around 920-930 Mbps both ways.

Clearly something is still wrong on the network side and by moving to a kernel-based mount you have managed to mitigate the problem, but not fix it. It might, for example, bea limitation of the way Kodi 19 has been configured to use libnfs that has revealed the underlying network problem. I came across this thread, admittedly five years old, that discusses such matters.