Vero 4K+ black screen, no connectivity at random moments/reboots

Hi all,

New member here and the first post from me on this forum is a support request, unfortunately.
Since about a week my Vero 4K+ has been acting up and I can’t quite get my finger behind the reason. It started with the device going black after finishing a video (not during playback). The device became unresponsive (black screen, no SSH, no IP even) but removing and reinserting the power connector seemed to solve the problem.
A couple of days later the same thing happened after a reboot. The reboot was because the screen was a lot darker than usual. That in itself looked like a problem I had a few months ago where the dim screensaver wouldn’t go full brightness after I started using the device again. In the end I ‘solved’ the screen saver problem by simply turning it off. Before the reboot, the screen looked like the device was stuck on the dim screensaver again.
During the reboot the device lost HDMI signal and wouldn’t come back up again. Removing and reinserting the power connector didn’t work either. I ended up having to wait several minutes before reinserting the power connector would result in the device turning on again.
After this the device has been unstable and some reboots go through without problems and some result in a completely unresponsive device. I have not tried playing videos again because I first want to know what is causing the the device to go into an unresponsive state.

The fact that the only way to make the device come alive again is to wait before plugging it in again worries me because that looks like a power or overheating issue and the device is only slightly warm to the touch during all this.

A log file can be found at http://paste.osmc.tv/ezizucutoh

If anyone could assist in getting my Vero back on track I’d really appreciate it. If more information is need I’ll be happy to provide of course.

Thanks in advance,
John

Hello all,

A small update. During a reboot, that resulted in a total lock-up, the screen was stuck on some lines (20191014 195318 1 — Postimages) for about a minute. After that it suddenly showed some more lines (around 20 or so) and then the screen went black.
I’m not sure if these lines are part of the shut down or boot process but the results of googling the last line “…Started Update UTMP…” makes me believe it’s part of the latter.

Do any of you guys know in what direction I should be looking? I’d really like to get my Vero up and running again.

Thanks in advance.

It may help if you can get a picture of the other lines.

If you can ssh in while it’s in this state, try this:

sudo systemctl stop mediacenter
mv .kodi .kodi.save
sudo systemctl start mediacenter

If that helps, then it’s probably corruption or a bad add-on.

I don’t know if it has anything to do with your issues but you have an error in your fstab file that is keeping the “Animatie” mount from being created and in that log I could see a file trying to be accessed from that non-existent mount…

The line starting with
//192.168.0.32/Animatie mnt/Animatie

should be
//192.168.0.32/Animatie /mnt/Animatie

How invested are you in your setup? A reinstall of OSMC might be the simplest solution

Sam

Hi all,

Thanks for the replies so far. Let’s see if I can nest my replies in one post.

@bmillham: Unfortunately, there is no connectivity when this happens. The screen goes black and the host doesn’t respond to ping/ssh. It could of course still be corruption of something.

@darwindesign: Thanks for the heads up. I fixed the typo. I don’t think this is what’s causing the problem though since the files from the ‘Animatie’ mount are and always have been available. Apparently mounting on linux is at least semi fool-proof.

@sam_nazarko: I thought about that but half of what worries me is how the behavior came to be. As you can see I have almost no add-ons installed and my Vero started doing this out of the blue after a really long run time (weeks) without any serious hiccups. Also, the fact that dis- and reconnecting the power doesn’t help and I have to wait several minutes before the device wants to boot again makes me fear it might be something on a deeper level.

Do you see any lights when this happens?
Can you please take a photo of the PSU you’re using so we can verify it’s correct?

Sam

This is because one or more things have become messed up and systemd will wait 90 seconds before a process times out. For example, you mentioned earlier

the screen was stuck on some lines for about a minute

That process, “Update UTMP about System Runlevel Changes” is hanging, probably for 90 seconds. If you can’t log on to the system, then you’re unlikely to be able to fix it interactively, which leaves you with a reinstall as the least painful – and quickest – option.

BTW, some people, myself included, have had more success reinstalling via an SD card than with a USB thumb drive.

1 Like

Hi all,

To get right to it:
@sam_nazarko: No light whatsoever. A picture can be found here: Foto Vero Power1 — Postimages. It’s the original PSU that came with the device.

@dillthedog: I can understand the system waiting for a period before killing or perhaps skipping a process during boot but what I can’t understand is the failure to start at all after being unplugged.
Perhaps my misuse of the word boot is causing some confusion. When I say the device doesn’t want to boot anymore (after dis- and reconnecting the power) I mean it doesn’t power up at all. The light doesn’t turn on and literally nothing happens. It’s like I’m turning the key in a car but not even the starter motor turns on.

Thanks for the tip on trying to use an SD-card as install media. I’m starting to realize a reinstall is currently the only viable solution and using a best practice can’t hurt. Also, if a reinstall doesn’t solve the problem I could look into trying to swap the PSU with another one. I’ve got a ton of these kind of PSU’s from different powered USB devices, that trick is finding one with the right amount of Volts/Ampere and right connector.

Try another 5V, 2A power supply (show us first if you have doubts) or use a USB-A cable (disconnect the power supply first). The Vero can be powered via USB

Cheers

Sam

@sam_nazarko: A reinstall (from an SD card) didn’t solve the problem. I also seem to have almost every cable known to mankind except a cable with a male USB-A on both sides. The same goes for the PSU. I have ordered a new USB cable though which means I can continue troubleshooting on sunday/monday.

To be continued. Thanks for the help so far, everybody.

Hello all,

I have connected an old 5V2A phone charger with a USB-A cable to the Vero and so far so good. As a make-shift solution it does the trick but it does cost me a USB port. Though this confirms it was a power problem, I don’t know if it was the PSU or the Vero internals that handle power (from the PSU). I suspect (and hope) it’s the former.

@sam_nazarko: Could you tell me if it’s possible to swap the PSU under warranty? If so, what are the conditions?

Just send an email to support@osmc.tv,
your order number and confirm if your address is the same.

Unfortunately the postman has just been, so it will have to ship tomorrow.

@sam_nazarko: First off, thank you for offering a free replacement of the part. It’s nice to interact with a company that offers solutions this readily and hassle free.
However, I think I’m going to go a different route which is to order a USB-A -> DC cable from a Dutch shop and use that with one of the 5V2A USB phone chargers I have lying around. I like modularity in my devices and it might be a bit more environmentally friendly considering I already own half of the needed components.

Looking at the cable of the PSU I have now it seems the specs you mentioned in a different thread (Vero 4K Power adapter specifications - #7 by fzinken) are still up to date so I’m going to be ordering the following cable: Google Translate after making sure the cable is center positive.

Yes – the specs for the cable are the same.

Sam