Vero 4k + bluetooth ear buds paired but no audio

Hi. I’m trying to connect some Jaybird Vista 2 ear buds over Bluetooth as my audio output device. Previous Jaybird Tarah Pro worked fine.
Vista’s will pair and connect but there is no audio output and under system\audio all I see is Bluetooth and Bluetooth hub. With the Tarah’s it would actually show Jaybird Tarah Pro as an output option and the audio worked.

After pairing bluetoothctl info shows:

	Name: Jaybird Vista 2
	Alias: Jaybird Vista 2
	Class: 0x00240418
	Icon: audio-headphones
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Vendor specific           (00000000-deca-fade-deca-deafdecacaff)
	UUID: Serial Port               (00001101-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
	UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
	UUID: Vendor specific           (9f92484a-37be-42d4-8d80-980ab7952390)
	Modalias: bluetooth:v01DAp0001d0100

The Vista’s are Bluetooth 5 if that matters.
I confirmed the Vista’s pair and play audio fine on other devices.

thanks for any tips

If you were seeing the device’s name in Kodi, that means you must have had a definition for that device in ~/.asoundrc. In the past, such a definition file was necessary. Nowadays, bluetooth will automatically connect to the last device it sees. You should be able to select either Bluetooth or Bluetooth Hub and get audio on your Vista 2s. Are you saying that’s not happening?

Ah right. I forgot about .asoundrc. That is indeed there and populated with “Jaybird”.

That’s correct. I can select either Bluetooth or hub but get no audio on Vista 2.

You could try adding the Vista 2 to that .asoundrc. Otherwise, can you show us some debug logs?

updated the .asoundrc with Vista2 address and picked Jaybird in output. No joy. Just silence.
logs uploaded
thank you

1 Like


2023-06-07 14:38:05.754 T:2930  WARNING <general>: CActiveAE::StateMachine - signal: 1 from port: OutputDataPort not handled for state: 2
2023-06-07 14:38:08.256 T:2930    ERROR <general>: Skipped 10 duplicate messages..
2023-06-07 14:38:08.255 T:2930    ERROR <general>: ActiveAE::FlushEngine - failed to flush

This could be tricky. I hate those ‘failed to flush’ messages. We haven’t updated bluez-alsa for a while. If I build a new version, perhaps you could try it out.

Meanwhile, do you get sound when playing files without Kodi? If you sudo apt-get install alsa-utils then try speaker-test -t wav -c2 -l3 -Dmybtheadset do you get sound?

No sound. Here’s the result:

osmc@kodigym:~$ speaker-test -t wav -c2 -l3 -Dmybtheadset

speaker-test 1.2.4

Playback device is mybtheadset
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 960 to 4194304
Period size range from 480 to 4096
Using max buffer size 4194304
Periods = 4
Unable to set hw params for playback: Device or resource busy
Setting of hwparams failed: Device or resource busy

Make sure Kodi isn’t still trying to access it: systemctl stop mediacenter and try again.

Same output i’m afraid. device or resource busy. kodi is stopped

osmc@kodigym:~$ systemctl status mediacenter
* mediacenter.service - media center application
     Loaded: loaded (/lib/systemd/system/mediacenter.service; enabled; vendor preset: enabled)
     Active: inactive (dead) since Wed 2023-06-07 17:38:27 EDT; 2min 5s ago

@tonymarotta Can you try this updated version of bluez-alsa?

Download the file to your vero and
sudo dpkg -i armv7-bluezalsa-osmc.deb

Reboot and see if it solves the problem. I’ve given this limited testing here, but if it borks things you can:
sudo apt-get update && sudo apt-get install --reinstall armv7-bluezalsa-osmc

Success! Thanks @grahamh Appreciate the quick turnaround and continued support.
Wife acceptance restored :smile:

1 Like