Vero 4K, bullseye-devel repo, video hardware-acceleration not working anymore

I am still running my 4K with the bullseye-devel repo configured. Yesterday my 4K promted me to update, so I installed it. Since then video hardware acceleration doesn’t work anymore, I just get a blank screen or sometimes I see the KODI menu screen when playing videos (different formats tested). Audio plays fine though.
When video hardware acceleration is disabled everything works, but the picture sometimes stutteres due to not enough decoding power.
Is this a known bug and is a bugfix coming? Or do you need some logfiles?

The development repository is experimental. It’s not for daily usage.

Is there a specific reason you are using this repository?


It was just configured since Kodi 20 test and I never removed it.
I tried switching to stable repo, but there is no update available to “downgrade”.


I’ve got the exact same issue, no video, since a update 2 days ago on my Vero 4K+ even in the main, not devel.
Here’s my sources:
deb Index of /debian bullseye main contrib non-free
deb Index of /debian bullseye-updates main contrib non-free
deb bullseye-security main contrib non-free
deb bullseye main
deb bullseye-devel main

Here’s the history of the two updated packages:
Start-Date: 2023-11-09 22:12:15
Commandline: /usr/bin/apt-get-real dist-upgrade -y
Requested-By: osmc (1000)
Install: vero364-image-4.9.269-36-osmc:arm64 (4.9.269-36-osmc, automatic)
Upgrade: vero364-kernel-osmc:arm64 (3.9.280, 3.9.281)
End-Date: 2023-11-09 22:12:22

Disabling the HW acceleration bring back the video (PVR, local files, add-on) but most of them at 1080 are really too bad.

I’ve tried to downgrade these two packages without success. I couldn’t find the kernel 3.9.280, just the 276. I suppose I didn’t have the right commands to do it. Any help would be appreciate to get back a working Vero.
Kind Regards,

Nope you have devel activated

Oops, True. I wasn’t aware and so sure I didn’t activated it (how?) that I didn’t see it. I’m not usually a Debian/apt-get user.
How do i deactivate it? I just erase this line or I else?
How can I repair my vero to main only?
Thank you,

Yes, but I would leave it in until you now get a devel update that fixes your problem.
After that remove it.

Today kernel -37 was released in the devel repo, but it still has the same problem (Failed to start VideoFirmware loader for OSMC SecureOS).
I manually downgraded to kernel -35 and everything works fine again.
I will remove the devel repo from my 4K then.
Or should I switch to another kernel version? Maybe from the stable repo?
Thanks, Marc

This should now be solved entirely.

Issue won’t affect Vero V, but we also rebuilt that kernel.

Please try updating now.