Vero 4K Cannot play some MPEG2 files

Hello everyone.

I’ve been using a Vero 4K for several years with minimal problems. I’ve recently digitised some of my DVDs to .mpg files which contain the original video, audio and subtitle streams from the disc.

When browsing the media library, I noticed that the metadata for some of these files isn’t displayed correctly in the bottom-left of OSMC. It just says MPEG-2 and 2.0 AC3 audio. Trying to play one of these files either results in OSMC “buffering” forever, or it treating the file like audio only, with a length of 10s of hours!

I have seen other people post about stuttering in MPEG-2 playback, but I haven’t found anything about this issue. My logfile is here:

Thank you for any help!

Edit: I forgot to add - I tried with MPEG-2 acceleration set to Always, Never or HD and up. None allowed the file to be played correctly.

This wouldn’t be related to any of the buffering or sync issues others had reported. This looks like your file just wasn’t created correctly. Have you tried playing this on anything else? VLC on a PC perhaps. I don’t think you made a valid file.

Thanks for your reply. I agree it could be the files that are at fault. They were created using DVDVob2Mpg. They play perfectly in MPC-BE though.

Have you tried disabling hardware acceleration for MPEG2?


Hi Sam. Yes I have. Unfortunately it made no difference.

A sample of an affected file might help