Vero 4K + CEC?

Hi All

Am i right in saying that if I set the CEC options to AVR/TV explicit and i use the included HDMI cable that if my AVR/TV are OFF, that pressing HOME on the 4K + Remote should wake up the TV/AVR?

If so, this is not occuring

Any suggestions?



Pressing Home shouldn’t wake your TV or AVR.


Hi Sam

What would wake the Vero on the Vero remote and allow the AVR/TV to switch on?

Ive tried another known working cable (works with the PS4)


Set Active Source usually allows this; but we need to be careful not to hog / hjijack the display. There have been problems with this in the past.

For now – you should be able to turn on your AVR / TV with the remote.


You need to be a little more clear about what you are trying to achieve.

Are you powering down the Vero, or just turning off the TV?

He wants his TV and AVR to power on when he presses ok on Vero remote.

1 Like

What my PS4 does is when I press the controller button to play a game, it turns the AVR and TV on and changes input

Im assuming the Vero does the same?

ie when I press PLAY on the Vero remote or Home, it should power on the TV/AVR, no?

‘Set Active Source’ where is this?

When you say for now, you can turn on the AVR/TV with the remote??? whats that mean.

Settings-system-input-CEC controller

I see nothing about cec controller

Ok, select peripherals

Ok theres nothing under the sub menu cec adapter abour set active source

So nothing at all in that menu appears to relate to waking devices?!

@sam_nazarko You’ve got to remove this “set active source” line from your vocabulary. It doesn’t exist.

What is it called these days?

Nothing I could see, there was an option (not at home now) that i set to AVR, but it didnt make any difference.

So can anyone tell me if its meant to power on the devices?

I’ve tested this for you and could start TV and AVR by CEC if I let wake them when the mediacenter screensaver deactivates, for this I

  1. configured the screensaver at settings->interface->screensaver (I used Dim and 1 minute)

  2. configured CEC at settings->system->input->peripherals->CEC adapter, see picture attached

(Hint: The Connected to HDMI device menu item only is shown if you first reset this CEC config to Defaults; if this is not set correctly, it does not work, here)

  1. restarted mediacenter/Vero4k and then disabled+enabled HDMI control/CEC on AVR and TV, so they can “learn” the situation

  2. if the screensaver is active and TV and AVR are in standby, a single press to any button on the Vero4k remote control wakes up TV+AVR (at least in my environment)

Since the various CEC-“dialects” and proprietary implementations, you can only try whether this is from help with your environment.


Thank you Jim, I will follow your instructions in the morning and see how I get on. I appreciate the detailed response!

Unfortunately it still doesnt work for me :frowning: