Vero 4K controller: only "back" button is working

Vero 4K controller: only “back” button is working

Only the back button is working, all the other buttons do nothing. I tried:

  • re-pairing the remote
  • removing and adding the battery
  • restarting the vero
  • installing 2020 from scratch (image on a usb stick)
  • installing 2021 version from scratch (image on a usb stick)
    Nothing fixes the problem.

Only the back button keeps working. What to do to solve this (or analyse the cause)?

Additional info:

This happend shortly after I tried to update to the 2021 version via: the OSMC menu option and started “check for updates manually”:
A blue bar appeared indicating something was downloading and disappeared.
Nothing seemed to happen, however from that moment only the back button of my remote still works.

As I have performed a clean install I would think this is a coincidence?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I uploaded the logging via a support ticket (#345580)

Thanks. I’ll get to this shortly.


I am up to date on all tickets.
Please check again.