Vero 4K crashed and went into boot loop

Hi all,

My Vero 4K might have just died. It was playing some music, while I was busy doing my household stuff without even touching media center. All of the sudden Vero 4K stopped playing and went into the boot loop. All I can see now is the black screen with ‘Please stand by’ in light blue followed by the blue screen with the white Vero logo and after that the screen goes black (apparently Vero restarts). And then it starts over with ‘Please stand by’ again…

I have removed all cables except for LAN and tried to connect via ssh. I can see a brief login screen and a couple of times I was able to enter login, but was not given enough time to enter password because PuTTY returned a fatal error message: ‘Network error: Software caused connection abort’.

My Vero 4K runs V19 Kodi, last update was done several months ago. I have added some new music to the library the other day and that it’s.

Could anyone please help me?



Sounds like the PSU may be failing. Are you able to try another 5v PSU?

If its the PSU, replacments can be found here:

Thanks Tom.

Hi @Tom_Doyle,

Thanks for your prompt response. Following your advice I have ordered a new PSU. Let’s see how it goes.

(I have placed an order for the wrong plug, US instead of AU, but emailed straight after asking them to correct my order. I hope someone will notice my follow up email).

1 Like

This has already been actioned.

@sam_nazarko, thank you so much!

Hi All,

Just a quick update. The new PCU arrived today. I have tried it straight away and voila! - everything is back to normal.

Many thanks to @Tom_Doyle and @sam_nazarko!

P.S. Two weeks without Vero turned out to be a real pain…


Glad to hear this.