Vero 4k+ crashes seemingly randomly

I’ve had my Vero 4k+ for a while now and was pretty happy.
For a while now it is acting up and I am not quite sure why.
Maybe it was because of an update? Maybe I did something stupid? Not sure.
This is nothing recent, but I tried fixing it myself and then ignored it for a while. Neither of it helped. :wink:

Here’s what’s happening:
On startup I would see the “stand by” message, then the blue boot-up screen and then… nothing - the TV just shows “no signal” and I can’t connect via ssh.

So I’d pull the plug and put it back in.
If I do this often enough (around 5-10 times) it eventually boots into Kodi.
There I can watch a movie and everything seems to work fine.
But if I do nothing and just leave it idle, eventually… boom. gone again.
As I would usually never turn it off and leave it idle, this is obviously quite tedious – in fact it’s basically unusable.
It’s hard to pinpoint the exact moment it crashes, except that it seems to happen quite frequently immediately on bootup or when idling.

I try to be fast and if I try often enough, I can connect with ssh to look at the log.
There’s a few errors (will paste link below) but I am not sure if any of them are serious or even related to what’s causing it. After all when I’m able to see them it’s either already past the point that usually crashes it or hasn’t reached it yet.

I’m open to any suggestions and will post any logs or the like that might help us figure this out.

Please let me know if anyone has any ideas.
For the above log it crashed, when I tried to return to the home screen after enabling debug logging.

Please enable debug logs and upload complete set of logs via MyOSMC.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Try changing your display settings in Kodi to 1080p 60hz. If not already set you will want refresh rate switching set to on start/stop in the player settings as well.

I also noticed your not running the latest update, although this shouldn’t be related.

I already did provide a log, with debug enabled. Did I miss something?

Sure, I can try that. But this is a 4K TV.
Running it on HD would be a waste and it definitely worked before.
But maybe it will help narrow things down.
Will check it tonight…

Yes, full logs means:

We provide simple tool for that

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

First of all thank you for taking the time to help me look into this.
It is very much appreciated!

oh, of course. sorry.
I read the support guide and thought it was an alternative for people who can’t access the log directly, not one which provides further information.

Here’s the output:
(btw, it took me 12 restarts to get it - there’s some quote about the definition of insanity…)

Sure, I’ll try that now, if I can get that far (it crashed right after I got the logs above).
Gonna do some more restarts, I guess… :man_shrugging:

Will report here.

This doesn’t look good

====================== Kodi Old Log =================== 2qaAc90c

---------------------- Kodi Old Log END --------------- 2qaAc90c

This means from your last crash nothing is recorded.

Anyway I saw that you have X11 installed. Suggest to try sudo apt remove x11-common and reboot. Than do update to latest version.

See this thread Vero4k+ OSMC October update problem - #10 by bmillham


Sorry, it took a while, didn’t find the time.
So I did all the above steps, uninstalled x11-common, updated and tried the display settings you recommended.

After the first two steps I saw no change and had the same game of multiple restarts to get into the GUI. The second (changing Resolution) seems to have done something, as I need considerably fewer attempts to get it to boot into the GUI. But maybe that’s just chance…

However the issue is definitely still there.

Here are the newest logs, shortly after which it crashed again:

Do you have any other ideas?

x11-common is still installed. What happens when you try to remove it

sudo apt remove x11-common