Vero 4k+ crashes when I attempt to play 4k mkv files

I am new to playing with this device. It was recommended that I have the resolution set to 1920x1080 60hz. The device is able to play lower resolution files just fine. Not exactly sure what else to do. Of course, Kodi on my PC plays 4k video without a hitch.

Here is a link to the logs:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I think you posted earlier on Reddit. We need a bit more information from you as Tom has suggested


Thank you, yes, after a bit of finagling I have the logs!

Can you share them?

I see you added them to your first post.

If I understand, Ford v. Ferrari.mkv doesn’t play as expected.

You seem to have a 128GB SD card attached which is failing.
Have you tried playing from local (eMMC) storage or a NAS?


Hi Sam,

Thank you for the reply. I had the SD card attached to gather the log data but I’m assuming it failed to write because it’s improperly formatted. The movie files are located on an external HDD which itself has power supplied separately by a usb hub. I haven’t tried playing from local storage or NAS. I do not have playback issues with lower resolution files. Is there perhaps a bottleneck from the usb HDD to the OSMC device? I have a Samsung smart TV and am able to plug this HDD into one of the powered usb ports on the TV and play these 4K video files, such as Ford vs. Ferrari, without a problem. Given that, I’d assume that the HDD is sending data fast enough. I haven’t attempted to access the device over the network and I’m not sure how to access the local storage. Any information regarding how to do that would be greatly appreciated, if possible.

Thank you!


This shouldn’t be the case.

Can you please post a log showing playback of the file with:

  • the USB unplugged
  • playback from local storage
  • debug logs enabled



A bit of a delay but I have it figured out. Operator error. It boiled down to the hdmi cable not being of a higher spec. Thank you for your help. I did learn how to connect to the device and write a file to the internal storage, so very educational otherwise!