VERO 4K+ crashes with 4K uncompressed movies

Hi guys,

I’ve had my Vero 4K+ for about 3 months now and everything works fine unless I try to watch a movie in 4K untouched on my server. The Vero crashes after a while or pauses the movie or picture turns green or distorted. I also find the Vero to be very hot. I installed it in a open space, not in a rack or anything and it has the latest firmware. Note my Zidoo X10 plays the BD 4K just fine.
Any tips?
Thanks!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Well I uploaded the LOG, I played the same movie and it paused several times, when I stopped the movie Kodi crashed.
Thanks

You have to paste/write the url here, so we can look at it.

https://paste.osmc.tv/etorujobaf

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I changed the settings as mentioned above. My skin is Aeon MQ8.
Still have pause problems in the movie, see log.

https://paste.osmc.tv/uqixuhip

There seems to be an issue with the log url you posted. Can you try uploading logs again.

sorry my bad:
https://paste.osmc.tv/uqixuqahip

Does your film contain a TrueHD track?
If you enable TrueHD passthrough, does the issue go away?

Sam

It’s just attached to my Panasonic FZ800, so not enabled.
I was planning to buy a second Vero 4K+ for my cinema room where I would enable TrueHD Passthrough but I still need to build the room because I just moved house.

Can you just enable it as a quick test? Mute the TV – or you’ll hear a horrible chopper like noise as your TV won’t be able to interpret the signal

I tried it enabling TrueHD passthrough and gotten no hickups or crashes. Is there a solution because I need to downsample to stereo?

Unfortunately this confirms an upstream bug in Kodi.
Hopefully there will be a solution in the near future.