Vero 4k+ crashing when resuming UHD content

I have a support ticket (Ticket no. #514078) open (with logs) but haven’t seen a response in a while so I figured it was best to start a thread as I’ve seen some older (similar) threads.

TV: Philips 55PUT6102/98
NAS: Synology DS1819+ running PMS and accessed over SMB.
Vero 4K+ (latest update) with the Plex for Kodi official app, all direct-play
Speedtest shows no issues whatsoever, files play near instantly when I click
Wired Gigabit Network

The following behaviour seems common across any UHD/4K files: Start Vero, auto loads Plex, playing the file, watching for a while then stop. Resume file and almost instantly it crashes (blue background with a sad face!), then auto reboots back to Kodi, then into Plex (that’s how I have it setup).

I was told that the last update was supposed to fix this, but it didn’t for me.

This has happened over a number of different files (x265/x264), various sizes and bit-rates.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Sorry, I responded to your ticket a few days ago but looks like I didn’t click Send.

I took a look at your logs.

Sep 04 14:24:13 osmc mediacenter[430]: Kodi exited with return code 139 after 0 hours, 0 minutes and 34 seconds

Plex is crashing Kodi. It’s unclear why. Can you confirm if direct playback over SMB without using the app works as expected? Ideally disable the add-ono.

Sam

So just directly play a file via Kodi and not via Plex?
I’m sure there are a lot of folks who use the official Plex app on Kodi to playback (and resume!) UHD content, odd why mine is causing crashes.

Will report back with results, though if it’s working fine in Kodi, then that doesn’t help me much because that app hasn’t been updated in forever and Plex are the only source for support. :frowning:

There is actually no “official” plex addon any more. The current replacement is listed in the information screen as Plex 0.1.6 by Plex. Is this what your running?

I’m running this, yes. Plex | Kodi | Open Source Home Theater Software

It’s listed as “Official Plex for Kodi add-on” and the author is “Plex”, if you go over to the Plex forums, there are numerous threads on this and sadly its clear that Plex has no further interest in maintaining this, though I haven’t seen any ‘official’ position from them on the app.

It’s just for a test.
Although PlexKodiConnect might work better for you.

Sam

Sorry I got confused as I didn’t realise Plex still had that up. I pulled mine from the fork that you had linked to in a thread back in July. It looks like that fork has not actually updated it yet. :frowning_face:

I have exactly same issue, did you ever solve yours?

Also I got this problem. Is there a solution?

/Söder

I just did a quick test and I was able to resume a 4k UHD file without issue using the official add-on both with and without transcoding to non-UHD. Are you running version 0.2.1 of the add-on from Kodi’s repo? You could also try accessing Plex through the “Composite” add-on.

When you say UHD, do you mean a remux or an encode? I got problem with the full remux files (the 40, 50, 60 gb files…)

0.2.1 yes. I’ve never heard of Composite but I got no problem with Plex Kodi Connect.

/Söder

The one I tried was only 20gb but I just tried the largest I currently have in my library which is 56gb and it picked up from resume without any aberrant behavior at all. Did you check your settings in the add-on to make sure you were allowing direct play, direct stream, 4K, and x.265? Without logs I don’t know what else to suggest.

You’re right. It’s not all of them it crashes for me with. I tried Mad Max (the modern one) and it happens, and I’ve noticed it on some others as well.

But now I tried Dunkirk with no problem.

Are these all files with a TrueHD track?

You’re right, Mad Max is TrueHD 7.1. The other one i tried now was some kind of 5.1 (DTS-HD MA 5.1, AC3 5.1).

But I will try 1917 as well. It say AC3 5.1 in Plex but there shall be TrueHD 7.1 as well. My receiver is pretty old but since it worked with Plex Kodi Connect I guess has nothing to do with what kind of system i got…

There we have it. I changed my 1917 from AC3 5.1 to TrueHD 7.1 and watched a short while, then stopped. When I then took resume OSMC crashed.

As i said, only in Plex client. Not with Plex Kodi Connect.

/Söder

I was using passthrough and that does not display the issue. It looks like 7.1 LPCM is also fine but 2.0 either with or without AC3 transcoding I was able to reproduce the crash. I then tried it with the Composite add-on and the same file with 2 channel or transcoded resumes without issue just like your saying PKC does. Sounds like an issue for the Plex forum as it seems isolated to their add-on.