Vero 4K crashing when seeking 4K movies?

I must admit so far it’s been a pretty smooth ride with Kodi via OSMC on the Vero 4K - been pretty impressed!

One thing I have noticed though, is that if you play certain larger 4K video files and seek around a bit (jumping using the number keys to seek to specific times is a good way to get it going) it does tend to make Kodi crash / sad face / relaunch.

Let me know if log files are required; I expect my particular configuration might have something to do with it.


Please post some logs and confirm if the files you are playing contain TrueHD tracks (known issue with Kodi)



Hi Sam - I was just retrieving the log. You want that here or via pastebin?

Please provide the My OSMC upload URL

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Here at Pastebin
I did try pasting it here with the “hide details” function but it easily exceeded the max char count

Yes every time this has happened it has been transcoding TrueHD files to plain ol’ DD5.1 (my receiver is old; DD5.1 gets passed through the TV to the amp via optical, I don’t use the optical on the Vero 4K currently but I will in future when hooking it up to my older plasma TV). It seems like you get three “seek” chances and then Kodi crashes, as a general rule.

I’ll try the My OSMC way now for convenience. It’s very easy to replicate. Oh I have a button on my remote for debug logging :wink:

Mmmkay, here we go :-

ssh grab-logs -A

I think this is just a known bug with TrueHD that is being worked on. If you had a newer receiver that could take the TrueHD bitstream it wouldn’t crash like that.

On an unrelated side note the cache settings you added are most likely less optimal than Stock (The Vero already has a custom value set that is different than stock Kodi). The “use limited color range” should probably also be set to enabled as well.

Yeah the cache settings were for testing; I can remove the advancedsettings.xml now and put it back to stock because we know the crashing is nothing to do with video cache sizes. Good reminder, thanks.

With Use limited colour range (16-235) this typically needs to be off on almost everything else that I run Kodi on otherwise you get a washed out looking picture with greyish blacks. Interestingly, here it doesn’t seem to make any difference (i.e. no harm leaving it on full). My 1080p BRAVIA panel is a bit of an oddity because it supports 10-bit colour and this is the only device I have which takes advantage of that. Seems to make a pretty big difference on some content though! 1.07 billion colours versus 16.7 million and all that. Enabling Force 422 coloursubsampling disables 10-bit.