Vero 4k Dead?

I have had my Vero 4K since 2017 and it has served me very well, but I sat down tonight to watch TV and noticed there was a flickering red light on the front which isn’t normal, which I switched to the Vero and I was not getting any video output.

Bit of research on here suggesting it could be a power supply issue but i checked it and it still has an output of 5.3v, unfortunately i don’t have the equipment to check it beyond its output.

i also read sometimes a re-installing can bring it back to life, which i tried but it doesn’t even recognise the USB stick i prepared using the installer, there is also no output or installation screen as suggested there should be.

Is there anything else i can try before consigning the vero to the bin?

Hi,

Try a different PSU or power via a USB A to A cable.

Thanks Tom.

Dont have a powered USB-A cable and dont have another suitable power supply.

From other threads i have read on here, i know there is a difference in what the red LED is doing but in my case the LED isnt flickering as i first thought, but is in actual fact solid and consistently so.

Flickering red light probably means the device isn’t getting enough power to boot.

Sam

1 Like

but its not flickering, i know i said initially i thought it was, but on closer inspection it is not flickering

Brainstorming what you can try:

  • try to power the Vero just using a USB A male/male cable to verifiy it’s a PSU issue
  • buy a new appropriate PSU
  • re-install the Vero using an SD card
  • re-install the Vero using the SD card and the toothpick recovery method
  • if all the above was tried and the Vero cannot be installed even using a new PSU, you can send an email to support@osmc.tv with the order details so warranty can be checked and further help can be discussed using that communication channel

Hi,

Have you any usb devices (drives, hubs), attached to the vero4k?

Thanks Tom.

Yes! This solved my problem (red light flashing, cannot boot)! :+1: I’ve used USB3 A-A cable (into white port on Vero4k) and now it’s OK! :slight_smile: So there was an problem with original power supply adapter into wall. Thank you for this information!

Nope, no device plugged into it.

As i suspected, i have since tried a new power supply and its still dead, so unless i have a second dead power supply its my Vero 4k that’s at fault and as it was bought in 2017, its very much not under warranty.