Vero 4k+ dead (?)


My Vero 4k+ have been serving me well since 2019, but looks like it might just have died today :cry:

It all started yesterday: I was listening to music on it, and when an album finished, I wanted to put on another one from the web UI, but it wasn’t loading. The iOS remote wasn’t working either (I think it uses the same endpoint as the web UI anyway), so I SSH’d into the device and rebooted it. Things worked again for a while, I listened to some music, but then after sitting idle for a few hours it disappeared from the network again, and I couldn’t reach it over SSH either this time. I power-cycled the device but to my surprise it didn’t boot up at all! There was no signal detected from the HDMI port, and as I’ve disabled the front LED from settings earlier I didn’t know if it reached any stage of the power-on process…

After this I’ve tried reinstalling OSMC from a USB key, but nothing seem to have happened when I plugged in the power adapter (no video output, no network activity, no LED activity on the USB key). I tried holding the internal reset button for 30s with a toothpick but it didn’t do anything either…

The power source itself seems to be fine, because when it’s plugged in I can see the red glow inside the TOSLINK socket; so power does reach that part of the board at least.

Does anyone have any idea to resurrect my Vero 4k+? :pensive:

(And just to vent here: after all of this, I’ve decided to temporarily repurpose my rPi from running pi-hole to run OSMC, only to find out that the SD card reached its end of life, after reimaging it with OSMC. :melting_face: I guess no music for me today…)

Do you have another power supply that you could try?

I had similar issues and despite red light in optical and reinstall it, but the issue remains when trying to play a movie or whatever. It turned out to be the power supply, after testing the power supply, it had 5v but 0,2 A, which is to less. I found another powersupply with same requirements and then vero 4k+ was running smoothly

So i advise to the powersupply with test for the amount of A. Test it with another one.

The PSU specs are: 5V, 2A center positive, 5.5mm OD; 2.1mm ID
You can grab them here;


You could also power temporarily via a USB-A cable as a test


1 Like

I’ve checked every adapter in the household, but either the diameter was wrong, or the voltage (12V).

Also tried with a USB-A → USB-B cable plugged into an external HDD enclosure, but it didn’t even power up the TOSLINK port.

That would not provide power, you would need a USB-A to USB-A cable and connect to either a PC or a USB power supply

I see! Ok, I’ll try getting one of those fabled USB-A-to-A cables then! :thinking:

Good news! I bought a USB-A↔A cable and the Vero got resurrected! :partying_face:

Now the only question is whether it’s the old external power supply that’s faulty, or something internally with the power connector :thinking: Although, maybe I’ll just keep running it like this forever… Is there any drawback to it?

Drawback 1, you are down one usb port (only have 2 on the Vero)
Drawback 2, you might have power issues if you plugin anything other on the second usbport that requires power.

Drawback 3, at least for me, a usb cable breaks for more often then a PSU-cable in my experience, and the barrel connector most people know is power, and wont accidentally remove.

There might have been a cost involved in getting that elusive usb-a → usb-a cable, but I do belive buying another PSU/“Wallwart” is in the end a preferred solution. But that’s just my $0.02, have a great day.

Using a USB port is only for testing – it won’t keep your device stable.

I would suggest getting a replacement power supply.

You can grab them here;


Hmmm… But then the same power supply would be prone to the same kind of failure, wouldn’t it?

What if I instead buy one of these? 55157 Goobay - Cable | USB A plug,DC 5,5/2,1 plug; black; 0.5m; Core: Cu; USB-DC5.5/2.1-0.5 | TME - Electronic components

I have a bunch of USB chargers laying around from old phones - might as well use those :thinking:

USB chargers are intended to charge batteries where maintaining voltage while there is a demand for amperage is not critical. The Vero needs a power supply since they are designed to maintain a constant voltage while under load.

1 Like

All power supplies eventually fail / degrade over time.

If you think another one is better then by all means go for it, but powering via USB will only give you half an amp which will lead to instability problems.

Really? I’ve been letting my vero4k+ run off the power from my usb hub (which I was already using to supply the power to the attached hard drive) for the past year or two, and can’t say I’ve noticed any issues. I’d say that for stability, the best thing you could do is plug everything into a UPS that will protect your devices from all the normal power fluctuations that your home likely deals with.

I guess I’ll plug my walwart back in (also to the UPS!) if it is likely to actually be a potential issue.

The Vero has the ability to draw more than 500 mA and the USB 2.0 spec is rated for a max of 500 mA and so the potential exists that if your player starts doing something that takes current over that USB spec then potentially it could then lead to voltage drop that could then potentially lead to instability and data corruption. As such, powering it this way is not going to be something that is “officially” supported, recommended, etc. outside of just using it as a diagnostic tool. There may be warranty issues as well (I don’t know, but just to state it just in case).That being said, it is your equipment and you can do what you want. If your having no issues over an extended period of time then potentially in your particular setup with no other devices trying to draw power, you could continue running it this way without issue. If you did so, and one day you started getting unexplained crashes or other odd behavior, then a PSU swap should probably be the first diagnostic path.