Vero 4K+ died, no display signal, red LED only

Sadly, my 4K+ after several years of service seems to have died the other night. I think when I found it the LED was not on but the device was plugged in, however no display signal was going to the TV. I removed the power cable and plugged in again but nothing happened. So I left it a day or two and tried again. Now it will power on until red LED shows, but no display signal is sent to the TV.

I would say here that I have been having random freezes and reboots moreso in the last few weeks, but I just put that down to running the nightlies.

So far I have tried reinstalling the OS image to microSD and powering on but it still goes no futher than red LED. (Not sure about that anyway as the OS was running from internal storage before?) SSH is also a no go. Anyway I’m guessing this is internal storage failure and I’m goosed. What say you lot?


The 4K+ doesn’t have an LED. Is it a Vero 4K instead?

It has a red plus + sign LED on the front. Order email says it’s definitely a 4K+. Thanks


Sounds like you may need to try another power supply (5V,2A), or power the device via USB cable as a test.


Hi Sam

I have a USB-A cable but nowhere to draw power from unfortunately, so looks like I’ll just buy new power supply instead.

I can see plenty online but just wanted to check the measurement of the jack before ordering.


You want a 5V, 2A power supply.


1 Like

I saw something like this on a previous firmware version. After a lot of tail and error is discovered I could get it to boot like this:

  • Unplug power and the HDMI
  • Plug in only the power
  • Wait till the red plus turns off (if this doesn’t happen its not the same problem as I had)
  • Wait a second or two and then plug the HDMI back in
  • You should see it booting (sometimes I had a black screen for a while but eventually get the home screen)

I will add that my problem seems to have been fixed in a firmware version from early this year or end of last year.

This sounds like you may have forced a video mode via the fw_setenv command.

If you still have a problem, I suggest a post with output of fw_printenv



just a follow up post to say that a new power supply did the trick.

thanks all