Vero 4k disconnect wired

So my vero 4k is turning off / or disconnecting, its in a remote room so only use it from SSH and as TVheadend server

I disconnected power and reconnected, after a min or 2 will disconnect again when i checked for updates it said it could do some due to time, checked system and it was 4 days out :confused:

so ive run the bellow

Sudo systemctl stop ntp
sudo ntpd -qg
sudo systemctl start ntp
ntpq -p

then did updates and all went through and everything seemed to be working for 30 mins, but now the system is showing time around 40 mins less than actual time, and its back to disconnecting, im on kernal 4.9

any other suggestions?

doing anything on SSH generally gives me a few minutes before i get disconnected

Some logs should give some clues.

What’s connected to the device?
If you have power hungry peripherals attached, make sure you are using a USB hub.

direct to router.

yes all devices are in powered usb hub have been sice i got it ages ago, so nothings changed hardware wise

is there any way to start logs via ssh? but like i say it boots me off sometimes within a minute.

ill see what tv displays tomorrow

You could run grab-logs -A.

It would be good if you could connect the device to a TV for a period and see what happens.

^^ just run, so about 11.40 last night it disconnected but system showed about 11.12

current date and time is correct

Wed Feb 17 13:12:47 GMT 2021

now been up and running 45 mins and still ok, an obviously nothings changed as im not at home :expressionless:
i have noticed 1 TV dongle seems to be missing on TVHeadend, other 2 are still showing as connected

The log shows that there doesn’t seem to be a connection to the Internet, though with an uptime of only 39 seconds, it’s difficult to be 100% sure.

As a first step, I’d suggest that you reboot your router and then wait a few minutes before providing new logs.

already tried that yesterday before 11, i do run a DNS server on a Pi this will be rebooted same time as the osmc as its on same remote plug socket, but this has been like that for over a year and been fine

its still up and running now, so turn on is identical each time through smart plug

Tried what? The log shows no ntp or http-time entries. Both require DNS.

rebooting router.

the dns server usually takes 20secs to boot, if there powers been off, so is few seconds behind the boot of osmc.

but in past its not affected osmc n why it was disconnecting from network

ill add dns to another plug, but set up has been like this working for 14month


If we can see a log that shows Internet connection, that would be a good first step.

Edit: You wrote:

How are you using the “smart socket” to reboot the devices?

problem i have is and @sam_nazarko I was told on the old kernel version the USB TV adapters dont boot right from a OSMC restart so only shows the realtek adapters, and not the sony ones. So I had to add a smart plug to turn both powered usb hub off and the OSMC, so meant I couldnt use the restart, had to use shut down then goto other side of house turn both off then turn both on. so system had everything connected.

I was hoping after 4.9 this issue with TV cards would be fixed but its still same.

Systems been fine since the times corrected, but when the OSMC first gets power the + logo is red then turns off, cant remember if thats normal or not.

the Pi with Pihole is on seperate power supply now, just thought its odd systems been fine run like that for so long to have that issue

Just to clarify. Are you shutting down the Vero4K first, eg using cron, before powering it down via the smart plug? Just pulling the plug on a Linux system is not recommended and will eventually lead to file system corruption.

(Of course, if you’d been having time-related problems, cron wouldn’t have run things at the correct time…)

So do you want to close the thread?

shutting down either via SSH or on HTTP kodi interface, then using the smart switch to turn off power and turn on back on to boot device back up.

Yeah you can close thread, could do with Sam advising if the issue with tv cards can be resolved so i dont have to power that hub off

Best to leave it open until @sam_nazarko responds re. the TV card.